Zero upload speed with Mullvad VPN on GL-MT3000 Beryl ax

I configured my router with Mullvad VPN. I get fast download speeds but 0 upload. I’ve tried different servers from different countries. I can use the Mullvad Android app and get fast download and upload speeds. Why am I getting 0 upload when use the VPN on my router?

It’s pretty sure not 0. Zero would mean that there is no Download as well.
How did you test it?

I used speedtest website/app.

I set my vpn up through the gl.inet app and just realized there is no VPN settings through the web interface. I have the CN version but I’m not in China, but I read through another post that there was a chinese law against allowing a VPN to be installed on the device. Even though I’m able to do it through the app, could this be why my upload speed is 0?

I get fast upload and download speeds through the Android app, but I’m getting 0 upload speeds on the Linux app also.

So try another speedtest - same result?

Yes, same problem each time. I can’t even interact with webpages when the VPN is active. Only the Andoid app gets upload.