A1300 Slate Plus Reconnect repeater wifi issue

If a fresh reflash of the current stable firmware won’t stabilize it, I’ll throw my vote in on a bad Slate Plus unless anyone can show otherwise.

I am surprised I havent received any correspondence from GLINET regarding this problem. If you read the changelogs and forum posts, this typw of issue is not limited to the Slate, but rather is affecting several, if not all, models.

When it works, it works fine. e.g., today it’s offline as a repeater. My main router performs an automated reboot around 0400 each week on Sundays. EVERY other router and access point/repeater simply reconnects and all is well. EXCEPT the 1300. I have to manually go to the device, connect to it with my cell phone (or other computer) login and try and refresh until it “sees” ANY of my devices. It always sees some, yet they are not anywhere as close as mine. After a while of refresh, nothing, refresh. It finally sees one and I can reconnect the router.

Maddening as this is very basic functionality.


Sorry for late reply.
Does your main router wifi use an automatic channel? and is the issue for 2.4G or 5G?
I guess some channel frequency is shifted (maybe for the reason of heat), and the connectivity is impacted.

I read through your posts. Two issues we need to understand.

First you are using USB device (as you mentioned SAMBA). USB 3.x device interfere with 2.4G wifi. So need to find out if this is the case.

Second, the main reason that wifi ssid cannot be found when scanning is the frequency. So I need this info:

  1. What is the channel of your main router wifi or hotspot? You can find out using wifi analyzer, or check if you connect from your pc.
  2. For a phone hotspot, pls say what country you bought/use the phone. The router may use a different country code, not seeing the hotspot due to frequency. This usually happens in the Europe from our experience.

With or without USB device., same problem.

Main router has been set to automatic frequency AND fixed frequency. Fixed frequency dtermined using both a hardware frequency analyzer and several phone apps. Multiple channels were tried. Always the same result. When router reboots or A1300 (or my older Opal) loses connectivity, it will not reconnect.

I am in the US and country code is set to US as per LUCI and SSH config viewing.


Which channel please?

Do you have the log from A1300?

I have tried each and every frequency available. As well as automatic.

No log is available.

No response?

Is there going to be a firmware fix for this annoying issue??

Can I check it remotely when the issue happens?

That’s kind of a silly question. If it’s not connected to a router, it has no connection to the internet so no remote.


So far, no one from GL Inet has contacted me about a replacement. I am beginning to think their customer service isn’t worth much

Here’s customer service email.

It’s possible if your PC has two NICs, with one connecting to the Internet, and one connecting to A1300. I’d like to check the logs and settings if possible. Sorry for the inconvenience.

Non client , server, nor router on my network has 2 NICs.

After much hullabaloo, Glinet finally replaced my Slate Plus. The new one once setup, it sees my cell phone and the house wifi access points and routers. It came with 4.4.6 firmware, but I dare not upgrade since that could have killed the one I am sending back!

Doesn’t look like I need any of the fixes on the latest release nor the 4.5.0 beta.

I will be monitoring the new one and reporting back what I find. I have my fingers crossed!


1 Like

I just wanted to let you know that I have this saaaaaaame exact issue with my slate plus. Though not so severe, it is always for some reason not seeing SPECIFIC wifi networks, generally the one that my tmobile home internet broadcasts uselessly, it has never one time been able to SEE that wifi network, yet all others can. Its weird, and its done the same with various others. I also have the same issue with repeater, and honestly, I don’t use it for that so much anymore. Its always too unreliable and it seems to NEVER stop trying to reconnect to the wifi network even after disabling it. Something is definitely messed up with this thing. I am now begining to think this issue is related more to hardware than just firmware… at least with the slate plus… I also just bought a flint 2 a few weeks ago and that flint2 worked GREAT for weeks until this evening it started crashing its wifi, dropping out refusing all connections until rebooting. It turned out, the slate plus was constantly trying to reconnect despite disabling repeater (as well as being connected via ethernet.) this constant reconnection despite it not needing to be connected (nor repeater enabled) crashed the flint2’s wifi endlessly and it took me about a half hour to figure out exactly what caused it. Now, the flint2 works great but it definitely has its own set of wide ranging issues. I’m just extensively disappointed and I’m wondering how these can be so buggy and problematic, when they are all on “stable” firmware. I don’t dare to upgrade them once things work. I think you made a good choice by not upgrading to the newest version on your replacement. Maybe my slate plus needs a replacement as well, I have no idea but I can definitely say my confidence in glinet… its just barely hanging on. :confused:

IMO everyone should have this app or one like it if the use Wi-Fi:

After 2 weeks of testing, the new Slate plus works better, but it still disconnects from the main router and does not reconnect. This occurs every 2-3 days.

I have to get physically close to it, connect with my cell phone, run the Glinet app, force the repeater to look for signals and then connect to the main router.

It’s truly a pain to do every time. WifiAnalyzer (which I use quite a bit) show no interference on any channels in use.

The main router is at a fixed distance from the Slate Plus and both have plenty of signal.

Since it has failed, I have NOT checked to see if it will still see/connect to my verizon cell phone hotspot.

Testing continues. However it is fairly obvious there is something amiss with the reconnection logic.


Now it’s happening every 11 hours. Going to cold boot/reconnect now.

Stay Tuned.


Here’s a stupid question but what power supply are you using… & can you test another (eg: USB cable + a ‘known good’ 5V/3A phone charger, single port)?

IDK what you did to summon so many gremlins, Rick, but that’s a bad case of 'em going on there.