A1300(Slate plus) Tailscale subnet is not adviertized with USB modem

I plan to use A1300 as an access router at remote site.
The router uses USB modem to connect internet.
I need the access to devices under the router’s subnet.

I setup tailscale with “allow remote access WAN” and “allow remote access LAN” option enabled.

When booting up the device only with USB modem, subnet route is not advertised to Tailscale client.

However if the device’s WAN is connected, the subnet route is correctly advertised to Tailscale client and can be accessed.
Once the route is set, it remains hours even after WAN is disconnected. I guess it works until the TTL is expired.

Is it known bug? Or there is something I can do to solve this?

Model: gl a1300
Firm: v4.2.3
Openwrt : 21.02.2
Tailscale: 1.32.2-dev-t
USB modem: Quectel EC25G

Check which interface has the priority metric, adjust accordingly, before bringing up your tailnet. ip route .


Thank you for replying, but I actually don’t get the idea.
Because it’s not Multi-WAN problem.
Anyway, I change the priority, but nothing has been changed.
The subnet route wasn’t advertised when only modem connected.

It seems it’s bug…
I’ve tried v4.3.2-snapshot for A1300, but it’s not stable enough to test.
Actually, it doesn’t recognize WAN…


So now that’ve I got a touch of coffee into me I see this is also a question of Tailscale… which is still a ‘beta’ supported feature.

It might not seem related but on other (stable) firmware the tethering interface gets a lower metric than Ethernet/WAN so it can cause unforeseen conflicts. I read your Quectel EC25G modem as such a device. I may be mistaken. The first thing I’d check is that everything runs as expected using said modem before adding on Tailscale.

Regarding Tailscale, which I personally don’t use, I’ve cooked up a workaround three days ago that’s been reported to work as expected. The Slate Plus & the Flint are similar enough any differences shouldn’t matter. It’ll require some editing of the stock GL script but it’s hardly complicated. Perhaps you can template from it.

(Though I would stay away from beta firmware unless there’s an absolute impasse on stable. Beta is beta for a reason, after all.)

Tailscale forces the use of as a virtual subnet, which happens to be the CG NAT used by many mobile network operators.
What are these 100.x.y.z addresses? · Tailscale
In other words, if you run Tailscale on Cellular, the IP obtained by Cellular is likely to conflict with the Tailscale virtual subnet, making internet access impossible. We are also working on a solution for all users …


I’m late.
I tried that Tailscale up command shown in this thread and it worked!
The reason is still uncertain, but I have a workaround now!
I haven’t implemented the scripts, yet.
But I have light, now.
Thank you so much!

As I checked /use/bin/gl_tailscale script and realized that it does support only wan interface.
So that I rewrite network.interface.wan to network.interface.modem_1_1 and it works.

1 Like

I’m glad you got it sorted. So it seems you’ve confirmed a bug &/or feature request for GL to address so that Tailscale honors GL GUI → Network → Multi-WAN → Interface Priority. I like to title my reports beginning with ‘[Bug]’.

Now might be time to make a backup given your custom workaround: