Accessing Flash Please Wait message

Got my GL-MT300A, great little device. I’m got my Samsung Galaxy S4 phone tethered to share out internet over WiFi and it’s working great.

I did run into a snag after inserting an 8 GB MicroSD card into my GL-MT300A. The card was formatted FAT32. On occasion while powering up the router, I see the message “Accessing Flash Please Wait” when trying to access the router’s web page ( The device seems to be hung and never seems to get past this - I’ve waited 30 minutes or more. Removing the MicroSD card seems to fix the problem.

Any ideas about this? Would formatting the MicroSD card with Ext4 or NTFS prevent this from happening? When no MicroSD card is inserted the problem doesn’t occur.

Also, is it possible to format the MicroSD card from the router’s interface?


Seems this is a new bug just found. Need to investigate it. The “preparing flash, please wait” message pop up when the internal flash is not ready, which will happen the first time the router boot. It should not relate to the MicroSD card.


Now on the router there is no format tools installed. However you can install it, it is fsck

Better to use Linux file system, e.g. Ext4, not FAT32. Even NTFS works better than FAT32.


Thanks for the info. Yes, that’s the message I get, “preparing flash, please wait”. I thought it had something to do with the MicroSD card, since the only time I saw it was when the card was inserted. Will try to document the circumstances better.

So what do we do now with this “Please Wait. Preparing flash” message?

I upgraded the firmware several days ago, but it has rebooted & been off plenty of times since then.

Tonight I uploaded a new OVPN profile & went to reboot (as someone else suggested that solved the issue of not being prompted for the password), and now I’ve got this flash message & can’t do anything.

Do we just wait for an update? Not even sure how we’d install it as there is no accessible interface!



@Jonny, most of the time, this is caused by installed too many packages, which fill the flash and there is no space to build the file system. It may happen if there is some settings caused the firmware not working properly, especially when you upgrade firmware and reserved the settings.

Can you reset the firmware by hold the reset button for 10 seconds. It will revert the factory settings and you can start over.

Thanks - I’ve now got the interface back.

However, I still can’t see any pop-up for me to enter the key password for OpenVPN (and therefore it fails with an incorrect password).

Any suggestions?


@Jonny, please purge your ovpn files and upload again.

GL-MIFI-777 out of the box, but instruction book is missing.
I get nothing except “Please wait. Preparing flash…”

Have reset numerous times in as many configurations as I can think of:
With / without Sim card;
Turned on / off;
holding reset up to a minute and longer;

Power on then try reset;
Reset with 1 cable plugged in;

Connected via wifi / ethernet

Since Instruction book is missing, maybe someone already bricked this then returned it to Amazon?
Maybe reset button is not working?

Since this is “new” , box was unsealed, maybe I should just return it and get another one?
What am I missing?


Returned product will not be resell. So this is not the case.

Fist, please check what browser you are using? Don’t use IE. Use updated firefox, chrome or safari.


  1. After boot up, does the wifi LED still light up? This indicate the MiFi actually work.
  2. When you press down the reset button, does the LED (wan or lan) start to flash, once per second? This indicate if the button works.

Hi Alfie,

OK, yes I’m using IE, will change to another browser; apologies bothering you if I missed this instruction somewhere.
Also, since no Owners manual included and was not shrink-wrapped, then possibly yes this might be open box, which is OK for Amazon to re-sell but should have been as open box / Warehouse category, not as new.

After boot up, does the wifi LED still light up? This indicate the MiFi actually work.
Yes Wifi LED does light up after reset and reboot.

When you press down the reset button, does the LED (wan or lan) start to flash, once per second? This indicate if the button works.
Yes lan LED flashs slowly, then faster, then faster again, then goes off.

Fingers-crossed its the browser, many thanks!

Thanks! Browser problem.

Weather Amazon will re-pack and resell is depends the sellers. We didn’t allow this option. Maybe opened by custom when importing.

Yes, browser problem, excellent!
New problem: I’m in Channel Islands (Guernsey); two of the three Service Providers is listed:
Jersey Telecom.
My provider is missing: which used to be Cable & Wireless

APN is “internet”
No pin, no Username, no password, nothing else
Service Provider Android guide
Sure help desk said there is also no dial number, so I will try Service provider 3,

Also btw, when entering password, it never changed to “password matches”.
It always said password doesn’t match when it actually does –

You don’t need to choose from the List, you can just type the info manually.

You just have to enter “internet” in APN for your operator, and it should work. No need to enter the password, username or anything else. Only enter “Pin” if your simcard has a pincode.

agreed, but only the list are options, no “Other” or blank on pulldown menu.
Bottom section blued-out; Username pin etc automatically filled out once Provider chosen.
Cannot type anything in, fields are protected, including dialing sequence.
Would be ok, but provider “3” is automatically prefixed in front of “internet” so APN becomes

“3internet” which I cannot overtype and change.

Ok lets start from the beginning.
Have you updated the Mifi to the latest firmware? v2.271

If not then download it from here:

Upgrade the firmware.

Reset the mifi by inserting a paper clip gently into the reset hole for 10 seconds. The LED of Lan will blink fast at 10 seconds, then release.

Now, once you are on the latest firmware, you should get “Manual” Or “Automatic” configuration of the 3G/4G as soon as you enter the connection info page at the bottom.
If you do automatic, it should work. If it still doesn’t, in the latest firmware it does let me change all the values after they have been filled in.

Updating firmware will be the first thing done, once it’s connected.
I may have gone a step too far now: How can I secure ethernet - only access?
Already password-protected wifi then turned wifi off.
But mifi could be used, just by turning it on and having an ethernet cable, couldn’t it?
So I changed to require phone pin, then changed the pin (did this in a phone).
Oops, now it won’t boot to where it was before, so there must not be a way to key a pin to the sim?
Thinking about it, that would be difficult – ok, thanks for indulging newbie dumb queries!

Ok so remove the Pin using the phone again, cos i had this issue. I would get no internet if i had a pin on the sim, something with the modem module or some bug somewhere.

Try without a pin and see if you get internet

Oh dear. Changed back so original sim pin and also pin is not requested.
Won’t connect. I think it did connect before, should have changed pin.
(sigh) Changed pin to original again, set to not request pin, which works on phone (phone doesn’t request pin) but still not working.

Might this be related?
Left column under “Settings” - next to globe icon, is completely blank. In help section this is filled in with “Internet Status”.
In tab Repeater, the SSID is blank and will not let me type either GL-MIFI-777 (original) or (I____) which was what I changed it to. Does this Repeater SSID need to be filled in?

Still not connecting, but it was, according to Provider help desk who checked - saw it connect an hour ago, now nothing

Try to reset the Mifi like i wrote before and start from the beginning?