Adblock not working on Mango and Slate 3.022 - solved


#1

Working to get adblock working on both the Mango and the Slate (3.022) and having a few problems with it not working.

In the end it’s pretty easy though:

SSH Session:
opkg update
opkg install adblock
opkg install luci-app-adblock

Browser into your router -> More settings - > Advanced -> Services -> adblock

The default screen looks like this:

Tried this and wouldn’t block ads :frowning:

Puzzled over, read lots and found that this works:


Instead of using the default uclient-fetch you need to use wget as the download utility
You may have to load wget (opkg install wget), didn’t look pre-post solving but I did an install anyway.

Don’t know if it’s because I’m running this in WISP mode but it appears I had to change the interface to LAN as well.


You can see in the first 3 attempts using uclient-fetch it’s actually not fetching or downloading any host files, but changing to wget has downloaded them and now works fine.

Assume this is the same across the GL-iNet range. Hope this helps someone :slight_smile:

(Actually just found another post that describes this after searching before…weak Google-fu …sorry for duplicate (but none of the other posts have pretty pictures :stuck_out_tongue: ) )


#2

thanks for the share. No problem for duplicate post.


#3

Is their any impact of parallel using some DNS options from the regular UI like force DNS, re-bind protection or Cloudflare?


#4

Force DNS: will override the custom DNS servers of all clients
Cloudflare: will encrypt DNS via tls
re-bind protection: will not resolve some local dns service

They do different things and should be used combined.

For example, if you use Cloudflare, but you didn’t use force DNS to override DNS resolve request of clients, one client can just set up a custom DNS server e.g. 8.8.8.8 from Google. So the DNS resolve of that client is not encrypted.

Note: if one client used its own encrypted DNS service, the router can no way to override that.