AdGuardHome on a Flint GL-AX1800 needs updating

AdGuard needs updating and wont update with the update button any idea how to manually update

Hmm, that’s weird. I was able to update mine to v.0.107.0 by clicking the update button. I am using the firmware 3.208


Hi I’m still on 3.207

Same here, snapshot 3.208 with AGH version 0.107

Is 3.208 stable I have tried a few reboots and switching off the VPN

I updated last night, for over 15 hours now wireguard VPN stays connected and AGH works no issue.
All seems to be OK for me.

OK i updated to 3.208 and than updated AdGuard and it updated with no problem than i imported my previous setting and still OK

1 Like

Another update AdGuard Home v0.107.2 and another failed update anyone else have this problem on the GL-AX1800 I setup my GL-MV1000 And AdGuard updated with no problem, it looks like a complete reset again, unless someone has come acres this.

Total reset and then AdGuard Home v0.107.2 has successfully installed, strange no one else has the problem

I have this problem now, can’t update to latest AGH. Restarting the router does not help in my case.

What I think I found is after you revert the firmware, make sure you don’t reinstall any provirus settings of AGH that stops it from updating

Hmm correct me if im wrong, but do you update via the package manager or update on the update button inside the adguard web ui??

I believe you should only use the package manager, if it happened that you have updated it on the ui from adguard you have to remove the adguard package in your manager and reinstall it I believe.

(Im not a adguard user)

As I was installing the beta at the time I dropped it in the box and then I made the mistake of using some of my backup files and then when AdGuard needed updating it wouldn’t, I found the problem one of the blacklist’s was no longer being used by AdGuard.
Just install the new update then I would update AdGuard straight after setting up your internet settings it should update with no problem at that stage.

I am having the exact issue right now… I could not get Adguard to even offer me the 0.107.2 until I removed Adguard and reinstalled it. Then it immediately asked to upgrade to the 0.107 on the AG Home page.

It failed and suggested to do it manually. I even turned off the VPN and rebooted and tried again…
Still fails the install.
I did notice something… Even after I removed the Adguard and reinstalled it. The Home Page still had all the stats. Are they saved on some NVR in the Flint?

Also I am sure you know. That once you remove Adguard it also removes the gl-agh-stats. Those need to be reinstalled or the fresh copy of adguard wont start.

There has to be a simple answer to this.

OK Revert Firmware and ounce it reboots set up your internet settings (so you have Internet) then start AdGuard go strait to the settings page of AdGuard it should update it works every time.

I must add i don’t have this problem with the GL-MV1000 so maybe its a little bug

Your are Correct

DON’T install by update button in adguard dashboard, loads a 34Mb+ program, Only use package in gl-iNET GUI or Luci. My advice after doing it.

Current Firmware : 3.208 Adguard Home: 0.106.3-1

1 Like

Yes i understand not to update the usual way but a little lost after that sorry its me being a bit thick, if you click on the information button if it don’t update it takes it takes you to a page with lots of AdGuard files but which AdGuard home to use did confuse me, is that what your saying

1.) Revert firmware
2.) Setup Router enough to have internet
3.) Do not activate Adguard Home yet
4.) Go to plugins hit update should update to newest package, If this does not work repeat first two steps load Luci, go to software hit update list should load newest package
5.) Restart router

Does that help at all Radiocrazy?

My GL-AX1800 has been up running for a week on 3.208 Firmware, Running VPN client, VPN policy, Adguard Home 0.106.3-1

Yes that’s what i did but not needed to update the plug-ins, but good advice if it should occur again, thanks.
For interest with AdGuard working and a VPN client how many DNS servers show on the Leak test, with no AdGuard its perfect just one which is used by the VPN.