Anyone Help with PuTTY & Tftpd64

Hi can someone help how do you get Tftpd64 to work with PuTTY I have disabled all security e.g. firewall antivirus etc, set the computer LAN to a fixed IP of, I have got the correct port selected and the correct baud speed to 57600 (for the router), using the routers TTL connection for the menu as shown.

I can’t upload the uboot or even the firmware I get the same message CHECKSUM BAD but the Tftpd64 just sits there with no logs or anything. This router was working fine when it was running openwrt-21.02.3 but when I upgraded it to openwrt-22.03.3 it bricked it, I was using the router to extend the range of my GL-AX1800 until it died, the router is an Afoundry AF-EW1200
I have the manufactures, eeprom, flash & uboot files.

Can you connect to your TFTPd from other machine than the router?

Sorry can you expand on that for me, thanks for the help by the way

I understand that you are trying to connect to windows machine running TFTPd from the router. So I asked you can you connect to the same TFTPd from any other machine for example VM ?

Can you list the setup and commands you used as well ?

I just downloaded the same application (tftpd64 for windows) and connected to it from another machine (Linux) to get a file - it works and you should be able to see in the log window of the application when the connection happens!

Are you sure you can ping your TFTP server? If yes, can you see the TFTP port? Lastly, if successfully connect to your TFTP server then try to disable “Option Negotiation” from the settings and restart the application.

You need to change your IP to the server IP or change the server IP set in the uboot environment.

Then in TFTPd make sure the IP select is that of the server IP.

I don’t know if I can ping the TFTP server so do I use putty or windows to do that,
I was setting the Tftpd64 as I indicated by the routers menu eg 3 for the computer card a 123 as indicted by the menu.
I don’t know how to upload a file to another computer, never done that before, sorry this I all very new to me

Are you saying both should be the same eg for the computers network settings and the router

If you look at the picture it states TFTP server IP is that’s the ip you server should have.

Which model are trying to flash?

When the router menu pops up it goes through lots of 0 & 1 then it reaches the choice of menu 1 to 4 7 & 9 if you chose say I it will halt the LED on the router goes steady, and if you hit enter it states the input device hit enter again it states server address these are set, hit enter a gain it will then ask for the file name hit enter again and that’s when errors come in.
The router is a Afoundry AF-EW1200 I did contact and they have found out that they are no longer trading, which was nice of them to check for me.
But would like to solve this but I may be a bit out of my depth, so apologies if I seem thick

I looked up online and found many posts by you on different forums for the same exact issue! It seems that you have been dealing with this since long time ago…

You need basic understanding of flashing and network connectivity! Anyway what firmware currently installed on your bricked router? And how do you connect to it ? Putty SSH?

How did you brick it in the first place?

Please refer to this:

Yes I have been struggling with this some time, openwrt-21.02.3 but when I upgraded it to openwrt-22.03.3 that’s when it bricked it.
Yes Putty SSH I have a serial interface connected to the 3 pins inside the router, I tried all the usual holding the power button down and hoping to see a flashing LED but didn’t get anywhere.
The router as it is without the serial connection just keeps disconnecting the LAN windows shows it as identifying network over and over again, but with the serial adapter I can get a stable LAN LED by choosing from the menu

Since you have bricked Openwrt just refer to the references I provided that might be of a help to you! You confused me when you said “the manufactures, eeprom, flash & uboot files…” why do you need to go back to the stock firmware?

I just mentioned this in case it was useful, i did try uploading the openwrt-22.03.3-ramips-mt7621-afoundry_ew1200-initramfs-kernel with the same result

I can’t ping the router using windows even though the LAN LED is solid, is it possible to use WinSCP to get into the router

TFTP won’t work till you fix the network connection between the router and windows machine

I have tried all the LAN ports how can i find out what IP the router is listing on, I’ve tried the original manufactures IP range which is, without the TTL Serial Communication connected to the router the LAN LED which is connected to the computer keeps losing a link (blinking every few seconds) obviously because there is no DHCP running on the router

sorry I can’t help for this model as it is not Gl.Inet.

No I ready appreciate all your help I know it’s not a Gl.Inet router and it’s nice of them to let me ask on here, I have three Gl.Inet routers now and I’m over the moon with them, I may have to ditch this and find another router to extend Wi-Fi coverage.
I did hold the reset down again and see if I could find a rescue mode but no luck, shame you can’t send the firmware via Serial Communication.
All the best