AR-750 Slate is a brick again - HOW do I get it unbricked?

I don’t see anything obvious in here that covers what I’m getting…
I downloaded the firmware file as instructed: openwrt-ar750s-3.212-0407.img

I watched the video.
I changed the address to 192.168.1.2
I held the button, plugged in the power, it blinked 5 times, I let go of the button.
I put 192.168.1.1 in the address and the “Firmware Update” screen appeared.
I CHOSE the file I downloaded.
I clicked Update Gl-Inet Firmware.

I sat back and waited, and got UPDATE FAILED.

At THIS POINT, I have NO IDEA what to do.
The “One thread to rule them all” is useless since it just says * In U-Boot, flash the 3.104 firmware (.img file)

I’ve got the firmware file for 3.212 sitting here and it fails
I downloaded the IMG file for 3.211 and tried that AND IT FAILS…

Can somebody PLEASE me how to get this #$%^&* Slate to load the firmware?

Do you have an ar750 creta or an ar750s slate? From the thread It looks like you’re using the wrong firmware for the ar750 if you’re using the openwrt-ar750s-3.212-0407.img

Is it a black router with antenna on the sides?

It’s a Slate - dark gray with antennas on the side.

And here’s the gl-inet page that say which one to download

Which one should I be downloading? Should I NOT be getting the for Uboot?

Have you tried following this post

This file

https://github.com/gl-inet/uboot-for-qca95xx/raw/master/bin/uboot-gl-ar750s-20201222-md5-901bf6ffffc79ff06aec709b669fdc18.bin

Should be what you need. Flash this in u-boot then flash the most recent stable firmware from u-boot

While waiting for a response I grabbed OLD .img files.
3.105 is 16.1 MB and it fails
3.212 is 17.5 MB and it fails
3.211 is 17 MB and it fails
The ONLY one that’s worked - and it’s currently updating is 3.203 which is 15.2 MB

Anyhow it’s updating at the moment. BUT, if the instructions work, I’ll try updating uboot…

I just looked at the “one thread to rule…” and the previous reply. What does “uboot failsafe” mean? Is it just 192.168.1.1/uboot.html?

I may have spoken too soon. Though it SAYS “UPDATE IN PROGRESS” it’s now somewhere around 30 minutes and it’s still not DONE… And the ONLY light that’s on on the Slate is power.

I’ll try to update uboot.

Yes, failsafe is the usual u-boot

I’ve been under the presumption that when the Slate updates Uboot, it’ll tell the browser it’s done. As in SAY “uboot update complete” or something similar.

DOES it do this?

'Cause after an hour or so of having the browser sit and the waiting circle circling, and only the power light on on the Slate - except every once in a great while the second light comes on, then the third, then they go off and it sits, I have NOTHING to tell me whether the uboot update failed or worked.

IT SAYS it has to be 20 12 22 or newer, and the one I downloaded IS 20 12 22.

At the moment, it’s supposed to be updating uboot again, so far with the same results as last time.

Went into uboot again. Gave it the uboot file the link was for, it started updating.

Though the Slate never showed any indication it was done, after a half hour or so I unplugged it, rebooted it into firmware again, and THIS time it took 3.212 and it SAYS it’s updating. I presume this means the uboot update must have worked. When I go to the Firmware update screen it now says uboot 2.0 version 20 12 22.

It got to the “UPDATE IN PROGRESS” screen, 2nd led blinked, then both 2nd and 3rd, and back and forth - this went on for 30-60 seconds with different leds blinking, then nothing.

Browser sits there with the “UPDATE IN PROGRESS” and spinning circle. Slate sits there with power light on and nothing happening.

I’m not sure WHAT should indicate it successfully did anything.

Eventually I unplugged the Slate and plugged back in normally. After 20 minutes, it’s still sitting there with the power light on and nothing else. No blinking, no booting, nothing.

What do now?

When you are doing uboot upgrade you are in the 192.168.1.x network.

If you have successfully loaded the firmware by default the subnet will be 192. 168.8.x once the firmware has been updated and the router has rebooted.

You need to change your device to 192.168.1.x to do the uboot update and once you’ve started the upgrade change your device back to DHCP.

By then going to 192.168.8.1 after changing to DHCP you should see the “Select Language” screen.

There is no “successful” screen from the uboot…

Hope this makes sense.

Well, through no great skill on my part, it APPEARS to be working.

I ran the 3.212 firmware again, let it sit - same as I did before - then unplugged it and moved it to where it normally sits, plugged it into the cell phone, connected to the power supply, and it booted.

I have NO idea why it would be any different THIS time than LAST time, but I was able to go in, set the passwords, rename the networks and set passwords, and it APPEARS to work

It’s STILL not very robust - if I move it or plug or unplug things it often crashes. In reality, NEITHER the slate or the creta - the OTHER router - is much for reliable. They both, on different cell phones, crash, lose connections, drop the network, and generally mostly work most of the time.

The Slate WAS normally the more reliable of the two, but over the last month or so it’s gotten extremely fragile - often just a touch or bump will crash it.

BUT, it appears to boot, it’s configured, and I can see data.

Thanks a lot for all the help. I’ll see how it goes later in the week when these two routers have to actually work for all the data connections while in a campground near a small town.

You have to start by installing 3.104 because bugs in the existing U-Boot in some Slate models prevent flashing anything newer.

You then update from 3.104 to 3.105 due to GL-inet GUI firmware update bugs.

Finally update from 3.105 (via GL-inet GUI) to your desired firmware.

Actually, I ended up having to update U-Boot to a new version that would accept firmware in a file larger than 16MB.