AR150 and Huawei E3372

I’ve just ordered the above USB dongle and a SIM card from Three UK. I’m hoping someone can help advise on the setup.

Once I’ve activated the SIM in the dongle will this just work when plugged into the AR150 or is there specific settings I need to use to connect?

Any help appreciated before I make any mistakes!

Check this guide https://docs.gl-inet.com/en/3/setup/mini_router/internet/

It depends if you E3372 is hilink or not. If it is hilink you may need to set up as tethering.

I think I read somewhere that the default IP address for the E3372 is 192.168.8.1
If this is the case then if you’re going to use this with your AR150 you will have to change the address of either the E3372 or AR150 as they’ll clash (assuming you’re using defaults on your AR150) !

you can always disable hilink via AT commands… i’ve done it for my e3131… you need to google for specific commands for your model…

tafazi

Thanks for the replies.

This was much easier than I expected. I had already connected my iPhone previously using the USB tethering function so not sure if that made it easier.

Anyway I simply plugged in the new USB dongle and the router automatically connected. The only thing I had to do, mentioned above, was altering the IP address as there was a conflict between the dongle and the router. I opted to change the routers IP. After that it just works. It’s using tethering rather than the 3G/4G option but it’s working well.

Ok so all working fine except one problem. I can’t connect to the VPN server running on my main router (Ubiquiti USG 3P). This is obviously being blocked by the AR150.

Can I just switch the AR150 into bridge mode as I don’t need any of its routing capabilities just to pass the internet from the LTE USB modem through to the USG gateway?

Any help on doing this please?

Have attempted to set Access Point Mode on the router but it keeps telling me I haven’t a cable plugged into the WAN port. I’ve tried plugging the USG into the WAN port but it still says Warning: no cable plugged into the WAN port.

All I want is to set this thing to Bridge Mode so that ALL internet traffic from the USB LTE Dongle goes straight to the USG and the AR150 does not do any NAT, Routing or Firewall.

Can you help @alzhao or @kyson-lok

The router does not work as bridge for modems and that is what the UI have showed.

@alzhao thanks for the reply. All understood but disappointing.

Is my only option then to use DMZ to the main gateway and have double NAT?

@alzhao @kyson-lok

OK have tried to setup DMZ but am still unable to access the VPN server on my USG. Currently the AR150 is setup with a static IP of 192.168.3.1 and it is currently providing a reserved IP to the USG of 192.168.3.242. I have enabled DMZ on the AR150 pointing to 192.168.3.242 but am still unable to connect through the the VPN on the USG.

How do I setup the AR150 to allow me to connect to the VPN on the USG?

So you have vpn server in USG? You want to access it from Internet? If this is the case you need to make sure your carrier give you a public IP. But this is generally not the case.

That’s correct.

How do I know if the carrier has provided a public IP??? What other type of IP is usually provided?

If you don’t know, then I think you can just forget about this. Carrier will not provide public IP if you don’t have a business agreement with them.

You’d better use some cloud platform to access your devices behind firewall. Sorry I don’t have ready solution for you now. But one is FRP. https://github.com/fatedier/frp

Ok thanks for that. Will look at other options.

OK I’ve now checked and I have a Public IP from my mobile provider.

So my inability to reach my USG is a problem with my config on the AR150 not due to CGNAT.

@alzhao can you advise what settings I need to ensure I can access the VPN on the USG connected to the AR150?

Have you considered IPv6?

Just saying…

Sorry I’ve never used it and wouldn’t know where to even start.

All I need to know is how to connect through the USB modem and AR150 to the VPN I have running on the USG.

Here’s my setup at present:

Huawei E3372 (Public IP) to AR-150 (LAN IP 192.168.3.1) to Ubiquiti USG (LAN IP 192.168.1.1)

So I’m getting confused with the three devices and their respective IP address settings. Can anyone help with the correct settings so I can access the VPN on the USG from the WAN side?

Sorry I don’t still don’t think your carrier allows you to access back to the modem’s local network,

@alzhao

I can guarantee they do! Three in the UK do not use CGNAT and many people are using this service to connect back into their home routers using the public IP or DDNS. The public IP will allow direct access back into the home router. I’ve already proved this with a borrowed LTE router in Bridge mode.

All I need to know is what settings I need to set on the AR150 to allow connection back inside the LAN using the public IP I have.

The problem at the minute, as shown above, is that the USB modem isn’t passing the WAN IP address to the AR150. It’s getting the LAN IP address. When I tether the iPhone, the AR150 gets the WAN IP.