AR300m Full brick

Hi all! I have a AR300M and I had recently a lot of problems. I couldnt flash to the original firm, the only one that worked was a Luci one. Couldn’t flash the original one from the gl-firms via nand or nor (on uboot mode). The router stays always with one green led without moving. I have tried a lot of them and nothing. Just the luci one, but i didnt like because it was very dificult to use.

So, Reading through the fórum I saw the posibility of flashing a newer uboot (oh no!). Thats what I did: flash. But the light went off. Now, the router is trully dead. I have connected the usb-uart and in the putty app, when I click on “open” the window just show me a black screen… I tried to find a tutorial, but I cant see. I dont know where should I start (if I can…)

Hope someone could help me. Thanks!

You can use uboot to flash the firmware. Debrick via Uboot - GL.iNet Docs

Hi! Thanks for your reply. But, uboot si bricked too…

The only way is to desolder the flash and program it with a flash programmer.

1 Like

Ok. Can I flash it without desoldering? I mean, if I make a DIY pin to connect the flash… or I need a programmer “yes” or “yes”? I am afraid to soldering it back again. I am not an expert with little solders.

I’m going to give a try. I thought that I would flash better with the raspberry, but with that maybe easier. On wednesday I tell you how it works. Thank you all!ÅMÅŽÕÑ&keywords=Clip+soic8&qid=1568666324&s=electronics&sr=1-6

Flashed! uBoot restored. But now, I can load the recovery mode but I can’t flash any firmware… let’s continue!

You can post you console log so we can check the problems.

Where is it? I think that maybe its the wrong uboot. I have the ar300m16 version too, can I use this flash?

Yes you can. You said uboot restored. So you get output from the serial port and you can post that.

ok! I’ll give a try. this evening (GMT+1., I am at work. Thank you a lot!!

Hummmm… I can access uboot through but got nothing via uart.

In additiom, only with the copy of my ar300m16. With those and no luck.

Nothing. When I Access to uboot it flashes the firmware, but when it reboots, there is only one green light. I have updated the uboot from but I am at the same point. It doesnt boot.

Does the connection UART serial port have any output?

There must be something output from UART. Otherwise you will not be able to enter uboot.
Pls check if you make the UART connection correct.

No output. Just the window in putty with no text. I think that maybe my USBTTL is not compatible (but I have used it to flash sonoff). It is an option. I have a raspberry or Im gonna try with the raspberry pi.

Check your pins - should only be Tx/Rx/Gnd - and your UART connection needs to be 3.3v

Anyways - if uBoot is running, follow the directions on the doc website… the pepe2k mod makes the ar300m almost unbrickable…

thanks for the help. I had similar troubles.

I can acces uboot. But via UART it is not working. I’ve checked all the conections.


DRAM: 128 MB
Nor Flash: 16 MB, sector count = 256
*** Warning *** : PCIe WLAN Module not found !!!
ath_spi_nand_ecc: Couldn’t enable internal ECC
Protect off 9F040000 … 9F04FFFF
Un-Protecting sectors 4…4 in bank 1
Un-Protected 1 sectors
Erasing Flash…Erasing flash…
First 0x4 last 0x4 sector size 0x10000 4
Erased 1 sectors
Writing to Flash… write addr: 9f040000
Protecting sectors 4…4 in bank 1
Protected 1 sectors
Warning: Bootlimit (3) exceeded. Using altbootcmd.
Un-Protect Flash Bank # 1
Hit ‘gl’ to stop autoboot: 0

no devices available
Device don’t have ART,please write the default ART first…