AR300m Full brick

thanks for replaying me

But I tryed several times ,… but nothing

I have no imput to link GL to pc … ;(

I show you an image that’s confirm I can’t reach the input via Web… non IP no DNS no reacheable…

I restart the procedure…
1- safeboot - both led are in stop mode (green & red) on

2 Set your computer’s IP address to 192.168.1.2

  1. no IP doesn’t appare

  2. I’m LOOCKED

Already sent. Thanks!

But how do they to retrive data from macadress?

seams strange… from where you get information about macadress ? if gl not work properly?

It’s in the ART partition…

Word to the wise - always keep that one backed up…

Good news!! I have restored one! I forgot that I made a backup of flash; the one that were working ok (AR300m16), and I made a copy of the ART partition. First question: Can I use it with the new one and change the MAC? The printenv only give me some values:

stdin=serial
stdout=serial
stderr=serial
ethact=eth0

When I tried to enter in safe mode it says “Starting HTTP server in ip 0.0.0.0”. I added other variables to enter in safe mode (with setenv), and I entered (yeah!). Still it doesn’t boot, I need to execute the command “boot”.

I have one problem with the first line:

setenv bootargs '...'

This line has been copied from the image that booted. But it’s too long and my terminal doesnt let me write the full line.

Anyway, I supposed that if I update the uboot it would update the variables, but it doesn’t. Here goes the second question: Is there anyway to do that via ssh?

Thanks a lot.

EDIT: FIXED BOOT ARGS

ok… cant flash art.bin

****************************
*      ART  UPGRADING      *
* DO NOT POWER OFF DEVICE! *
****************************

Executing: erase 0x9FFF0000 +0x10000; cp.b 0x80800000 0x9FFF0000 0x10000

Erasing flash...
First 0xff last 0xff sector size 0x10000                                                                                255
Erased 1 sectors
Copy to Flash... write addr: 9fff0000
Write failed, cross 16M is forbidden
flash.c[227] FIXME: rc=-1
## Error: HTTP ugrade failed!

I’m trying in /art.html and this is the error in the UART console.

You cannot update art.bin via http.

Do you have tftp? Check this doc

https://docs.gl-inet.com/en/3/dev/uboot/

Hi! The two units nos are working. FIXED. At this time the two units are with the same mac, but using clone mac I changed one until I could flash.

Yes, I have already checked and when I write those commands in console I am having the same error.

erase 0x9FFF0000 +0x10000; cp.b 0x80800000 0x9FFF0000 0x10000

you can try following command

erase 0x9FFF0000 +0xffff; cp.b 0x80800000 0x9FFF0000 0xffff

Nop. Bricked again. Restoring 3, 2, 1… :stuck_out_tongue:

I forgot to tell you to perform the previous steps.:crying_cat_face:

  1. You need to first configure the TFTP server and name your ART art.bin in the TFTP directory
  2. Set your computer network card to a static IP address of 192.168.1.2
  3. Excute following commands
tftp 0x80800000 art.bin
erase 0x9FFF0000 +0x10000
cp.b 0x80800000 0x9FFF0000 0xffff

Don’t worry, I did it first! I will try again today.

Hi Jichef,

can you give some hints how you have flashed the without desoldering the flash and with a raspberry?
Thanks in advance
Kai

Ey! Sorry, I couldn’t write you. I didn’t used a raspberry. I bought a chip programmer. and flashed a bin50029e61553e06cca53c441aec476f9e1d3f607d_2_375x500

1 Like

Ok, nice job man !

but stil you have problem about speed limits with 2.4Ghz ?

in repeater mode gl ar 300 goes under 10Mbs actually the internet connection is around 1000Mbs

Why^

Is this a: CH341A 24 25 Series EEPROM Flasher BIOS USB Programmer
You used?

Yes, the kit with the test clip. Not all sellers include it.

I have ordered one on EBAY, in the picture the clip is there I just have to wait until it arrives.
What software did you used to flash the chip?

I will try to get a backup of the now brocken chip first to see what I damaged :frowning:

I uploaded the one i use here:

https://filebin.net/knu1obqw4lqrfyjo/CH341A_programm_v1.34.7z?t=5apgmm46