AR750 and Wow-fi Fastweb

Is there a guide explaining how to connect this router with fastweb wow-fi?
I have tried various settings but I have difficulty.
Thank you

adapt for your neeeds


config 'wifi-iface'
	option 'ssid' 'WOW FI - FASTWEB'
	option 'device' xxx'
	option 'mode' 'sta'
	option 'bssid' 'xx:xx:xx:xx:xx:xx'
	option 'network' 'wwan'
	option 'encryption' 'wpa2+ccmp'
	option 'eap_type' 'peap'
	option 'auth' 'MSCHAPV2'
	option 'identity' 'myIdentity'
	option 'password' 'myPwd'


config 'interface' 'wwan'
	option 'proto' 'dhcp'


config 'zone'
    option 'name' 'wan'
    option 'network' 'wan wan6 wwan'

Cannot use the default web UI to set up?

@alzhao i’m on vanilla with no luci, but all you need for “fastweb wow-fi” is connect as client with wpa2+ccmp and peap+mschapv2 with username e password from provider… so it should be pretty easy…

lots of info if you google for “wow fi openwrt”, some reviews on also have positive feedback about gl.inet products and fastweb wow fi.

this is the best i can do for @Bobo360, maybe someone can post some screenshot for him.


Thank you very much, but are these commands to send?
If yes, how do you do it?

we talk about uninstalling “wpad-mini” to install “wpad”. But in my new fw 3.027 is it necessary?

Does this work?

1 Like

follow @alzhao suggestion first it should work.

1 Like

I try to make this attempt and let you know.

anyway, these commands are sent via Telnet?

you need to ssh to the router and use vi to edit files like /etc/config/wireless for example… but better do some reading first… basically you are using a linux system shell remotly.

1 Like

I red that many people had problems connecting with WOW-FI Fastweb so I was worried about that, and before trying to connect my AR-150 ext I red a lot of posts describing procedures. I don’t know if I was very lucky but it was a huge waste of time!
Following the essential but complete instructions reported on the manual I entered the GUI with the password, then I clicked on Scan, near the image: Extender, searching for WOW-FI Fastweb and when this network appeared I clicked on it. Then I typed username and password and… appeared Success! I was CONNECTED! (It was 2019.)
So why so many people had problems?
It is a good question for me. I suppose it was an old problem with the older firmware that was solved in the newest.