Gl-mt1300 不支持 802.1x eap/wpa2 peap/mschapv2 认证

你好,之前用的 GL-AR300M 迷你路由器是可以支持 802.1X EAP/WPA2 认证的。

最近刚买的 GL-MT1300 发现 不支持 802.1X EAP/WPA2 认证

尝试使用 AR750 and Wow-fi Fastweb 的配置文件方式,也是不行的。

固件是 https://dl.gl-inet.com/firmware/mt1300/release/

测试版:openwrt-mt1300-3.201-0318.bin

已经安装 wpad 软件包:

# opkg list-installed|grep wpa
wpa-cli - 2019-08-08-ca8c2bd2-5
wpad - 2019-08-08-ca8c2bd2-5

/etc/config/wireless 添加的配置:

config wifi-iface 'sta'
    option device 'mt7615e5'
    option network 'wwan'
    option mode 'sta'
    option ifname 'apcli0'
    option ssid 'OFFICE-WIFI'
    option channel '36'
    option encryption 'wpa2'
    option eap_type 'peap'
    option auth 'EAP-MSCHAPV2'
    option identity '...'
    option password '...'
    option disabled '0'

# tail -5 /etc/config/network
config interface 'wwan'
	option proto 'dhcp'
	option metric '20'

# grep wwan /etc/config/firewall
	option network 'wan wan6 wwan'

请帮忙提供一下可以 hack 的认证方法,感谢!

暂时没有办法呢。

MT1300跟MT300N-V2是不支持这个的。

not supported

MT1300 Support EAP in AP mode now.

Is the AR750S supported?

AR750S support connect to EAP as repeater

I have tried the last version firmware 3.203 released at 2021-08-09 .

截屏2021-10-18 下午10.31.25

It was still NOT supported connecting to 802.1X EAP/WPA2 WIFI under Repeater mode.

MT1300 does not support connecting to EAP until now.

It can support EAP in AP mode but this is not what you want.