AR750 - Need assistance setting up Access Point mode

You are totally correct. Let’s find out how we can do that.

The problem needs to be solved, how does a user know the correct IP address he need to use?

@alzhao I have set the router to a static IP (instead of DHCP), so I can connect to the router later on.

Currently, it seems like the logic only checks for a DHCP server, and if so allows AP mode.

I’m asking that you either remove this check, provide a warning, or check that the device has an IP from either DHCP or static.

I think we may just provide one option when you set up AP/Extender to let you an IP address. As we only got one requirement on this and once we add this, we need to deal with a lot of more issues, we will not be urgent to do this.

My main router and the AR750 both are using DHCP so at this point the main router does not meet the current minimum requirements as I still receive the message. To be honest, I feel the AR750 was a bit faster to connect to the internet when it was set as static as the system did not have to utilize DHCP on both routers. However, it is but not a big deal.

Eventually I will hope to update to the firmware which may fix this check in the future. For now, it appears I will have to be patient and wait.

I may need to purchase a replacement router soon as it seems the connectivity reliability may be going down as of a couple weeks ago. However, that is a different topic entirely.

Thank you all for your responses. It is greatly appreciated!

I suggest adding an option for the user to choose DHCP or static… Then it is up to the user to know the difference. Besides, the end-user would assign a static IP from the main router/network. At this point they should know to set the same IP to the AP. Giving a choice and recommending the DHCP option would help steer the less experienced in the proper direction.

Besides, the “anti-brick firmware installation recovery” process is genius for any issues that arrise. I have had to use it once myself a long time ago!