AR750 SD card slot used to share media?

When I insert a 128gb SD card, it does not recognize it to share media? What am I doing wrong? Or is this slot only for OS level flashing?

You can log into SSH and type dmesg and see if there is a message that /dev/sda is mounted.

which format has the SD Card? NTFS?

I didn’t have to do anything for mine. I have a 128GB SD card, and it pretty much worked just by inserting it – it shows-up under the “Share” section of the main GL web interface. By default, it is read-only unless you check the “Writable” checkbox, and it is only accessible via the LAN side, not the WAN side, unless manually enabled – are you trying to access it from the LAN side or WAN side? Also, for me, the card shows-up under the “Settings” section, under the devices subsection (the devices icon – the second icon from the bottom, above the “Firmware” icon), which allows you to view the contents of the device.

My card was initially exFAT, which worked, although I eventually installed packages to re-partition and re-format it as EXT4.

it doesn’t support plug and play. Pls reboot the router.

Did anyone find a solution for this? I have the same issue. I have tried formatting the sd card to be exfat, Fat32 and now ext4 and it’s not showing up at all.
Any help would be much appreciated.

1 Like

Can you ssh to the router and try go get the log and check if the card is mounted?

Try the following once you insert the SD card.


The AR-750 is very finicky out of the box. If you do not install any additional software it will not recognize many file systems.

I formatted my card 128GB card to be FAT32 instead of EXFAT and it works right away. I am having similar trouble with a USB stick as well and it looks like it can be solved by reformatting.

Which packages did you use to make ext4 partitions. Not working for me so far…

Also I have had problems accessing the sd card. After I switch the router control toggle to make writable in the web control, when I try to transfer a file onto the card on the network, the file utility says access denied. How do I check or change permissions or whatever is nessesary?

I installed e2fsprogs which provides mkfs.ext4

I ran

chown -R nobody:nogroup /mnt/*

Returned bunch of files with “operation not permitted.”

Now, it doesn’t seem to mount the USB stick anymore. Noticed that fstab is blank.

/etc/fstab is emtpy by default (except for a comment)

the sd card (and usb storage) is mounted via usb hot plug in:


the device has to be formatted with a supported filesystem:

if [ “$s” != ‘vfat’ -a “$s” != ‘ntfs’ -a “$s” != ‘ext2’ -a “$s” != “ext3” -a “$s” != “ext4” -a “$s” != "exfat
" ];then

Why do you think it is not mounted?

You can refer to this post. AR750s MicroSD troubleshooting - #3 by kincheng

The situation is not exactly the same, to see if it can help you.

I couldn’t insert a card in an operational AR750 and have it work. However, when I inserted the SD card and THEN powered the router, it worked fine. For me that is a fine work around.