AR750 - SD card with ext4 and NTFS partition

Hi all,
my SD (16GB) is formatted with two partition like the subject.
ext4 is used for extroot (3GB) and i can see it, NTFS for data/backup, but i can’t see it:

image

can see only here:

suggestion?
thanks

SOLVED:
I had to mount:

  1. get information with blkid command
  2. insert this string in /etc/fstab: UUID= < what i got from blkid > /mnt/NameDirectoryToMount ntfs defaults 0 0
  3. mount /dev/DiskLabel /mnt/NameDirectoryToMount -o rw

now it appears:

image

1 Like

Just noticed that after reboot i lost my configuration in /etc
Anyone can help me?

image

when you reboot, do a “sync” first. This force writing all buffer to disk.

Just type the command in shell.

sync 

doesn’t work.
After reboot my AR750 continue to ignore my edit to smb.conf and doesn’t mount my partition on fstab:

i tried from gui too:

getting crazy! lost my life editing /etc/fstab but real file for working changes is /etc/config/fstab
madness with extroot

1 Like

I understand. It is not a problem of exroot. It is openwrt.

For example, you cannot modify smb.conf because it is dynamically generated. You need to modify smb.conf.template instead.

The same for fstab.

1 Like

perhaps maybe this might help?

In vanilla openwrt I use extroot and create 2 ext4 partitions. usually first one between 1 and 2 gigs depending on extcard size and mount it to /overlay. the second I mount to /mnt/sda2/. with gl-config it always mounts to the partion label names automatically and on hotplug for non permanant drives. so with extroot in mounts 1st partion. after booting you then have to set another mount for second partition. one way I do it. prolly more than one way to mount a drive but for I while I too fell into a trap of doing it wrong.

1 Like

no way to solve, this is the situation

etc/config/fstab

image

/etc/fstab

image

always mount this mount

mtab empty. 3days working all day and no solution

  1. pull usb thumb drive and reboot.
    verifiy you or only mounting the single partition of /overlay at boot. (it will be unmounted because device is not pretent). delete other mounts leaving overlay. powerdown instert usb and reboot extroot. and verify uuid is pointing to correct partion. if not delete all and point to /dev/sda2 and make sure directory /mnt/sda2 is already created and empty in openwrt (umount /dev/sda2)

  2. since windows cannot see ntfs partions on a drive past the first ext4 ntfs may be corrupted and need to to fix it other than with windows?

so I’m thinking? why use ntfs on thumb drive?
my bad. I’m thing all is on one drive.

ntfs partition is on /dev/sdb* correct?

when i mount with mount -a everything working fine, i can see ntfs partition from my windows pc and from my raspberry
so the problem is on boot
i’'d like to know in which file the router takes this output, overriding all fstab files
https://forum.gl-inet.com/uploads/default/original/2X/c/ce0c62dda940ce0c85199c4a1d7e0962fd4d7a4b.png

image

image

ext4 is booted in exteneded partition?. I always use a prmary partion and always the first partion. what os did you use to format ntfs or what version.

maybe that’s the problem? can i flag sda5 as primary?
I format SD card on my windows pc by minitool partition wizard

I don’t believe so that’s in the partion table. perhaps you can backup the data and delete extended partion and reformat as ext4 primary. you will also need windows software in windows for mounting under windows or if you use linux it shouldn’t be a problem so long as both support writing to ntfs and not read only to ntfs.

getting crazy again, but…SOLVED!
i tried everything, formatted again to get sda5 label, tried over 1000+ options in /etc/config/fstab, tried also the official guide https://openwrt.org/docs/guide-user/storage/writable_ntfs

but the only solution to automount NTFS with write permission is this:

now after reboot:

so… package conflict… just madness again
hope this help in the future
thanks all

2 Likes