AR750s Keeps disconnecting

Does you use your tplink router in hotels as well? Do the router automatically connect to different SSIDs as well?

As I said in another thread that you can disable repeater manager which could be the reason.

1 Like

I don’t carry that piece of junk with me when traveling, I bought the slate because its small and should be powerful enough to replace those big, static routers. Well it does nothing automatically, it just connect to whatever SSID you set it on.

Can you elaborate please? Or a link to the thread so I can try this solution and see if it improves my situation.

@Alzhao: I respect and understand what you are saying but the much cheaper AR300M (which I replaced with an AR750S) managed to broadcast and repeat 2.4GHz without problems - it worked much better than the Slate without any tweaking of settings - there must surely be something not quite right with the Slate.

As you proposed, I now repeat on 5Ghz and use 2.4Ghz for clients (as per above user, most of my devices do not support 5Ghz but luckily my router does!).

1 Like

Actually I read all of your feedbacks. Some claims Slate is not stable as AR300M but some said it is okay.

I continuously test the products and I didnt observe obvious differences. But we will do another round of testing to find out the problem.

1 Like

Pls check this one. Tip & Feature Request re regular WiFi dropping - #11 by jas8522

We have a program called repeater manager which will manage the SSIDs you have saved. It works good most of the time but seems it caused troubles in some WiFi network with captive portals. There is still room to improve and we are working on that.

1 Like

@sos_sifou: Can you use the travelmate package to test in your environment? The steps are as follows:

  1. Delete the gl-health package and kill the gl_health process.
  2. Install travelmate and luci-app-travelmate
  3. Enter the luci page


I have followed the advice of Alzhao, and I add # to the line of gl-health in boot, do I need to completely delete de file?

I will do all the above steps and report back

Thank you

@sos_sifou: You better delete the package, this process may be pulled up by other operations.

Thanks for posting - Travelmate looks interesting.

@glitch:Tomorrow I will go outside to look for similar environmental tests, so if the travelmate test works well, our firmware will add this feature. Of course, it is best to pass the verification in your environment.

Does this solve the issue of the router dropping connection to the Access Point? or is this only for the issue of the router dropping its own LAN WiFi? i think we have 2 separate issues here. The dropping of the LAN side WiFi from the router was a small problem for me, the main issue was the AR750s dropping its connection to the Access Point that it is trying to repeat

I echo those sentiments although if I lost AP connection, my clients also got dropped (router appears to reboot, or at least the LEDS go out).

@jongriff :In fact, these two problems are related. The openwrt system will cause its own AP signal to be abnormal if the repeater connection fails. Therefore, we have added the gl-health process to handle this situation. Gl-health may not work well in some environments, we are trying to fix this.
For travelmate, please see the following link packages/ at master · openwrt/packages · GitHub

I installed travelmate, set it up as requested, but I really don’t know where to find gl-health to delete it, is it a package ?

You can ssh to the router, and execute those commands.

killall gl_health
mv /usr/bin/gl_health /usr/bin/gl_health_bak

Putty is returning the following lines, does it mean that gl_health is killed and deleted completely ?

What if I full reset the router, will gl_health be restored again ?

root@GL-AR750S:~# killall gl_health
killall: gl_health: no process killed
root@GL-AR750S:~# mv /usr/bin/gl_health /usr/bin/gl_health_bak
mv: can’t rename ‘/usr/bin/gl_health’: No such file or directory

Fully reset the router to ver3.009
Ssh killed and deleted gl_health
Installed travelmate and luci app support
Set travelmate to 1 enabled

Testing now and will report back in few days

Hello guys,

Update 1 Using Travelmate Service on the Slate AR750S

After some time testing with the above config, I can report the following:

  1. Used it in office as my main network device, so far so good, no frequent disconnections
  2. Using it at home also and so far no more disconnections, neither from the main router to the slate nor my devices from the slate
  3. Will be traveling soon and will test again with hotel wifis, captive portals and so
  4. OpenVPN is working on this firmware
  5. Can’t seem to be able to connect to any network using Luci. From the Slate interface it works well, I dont know if its only me not knowing exactly how to use Luci.
  6. Cant repeat 5G wireless connection, only 2G can be used, but still can broadcast 5G from the slate
  7. Firmware ver3.013 is a no go, I tried it but it was not stable, Open VPN didnt work for me

Judging only from what I am experiencing right now using the Travelmate service, this feature is A MUST HAVE on the Slate, I would love to have it integrated into the main interface (not Luci), for me it will be always ON, or maybe we can switch it on and off directly using the hardware button.

I successfully installed Travelmate but the instructions are sketchy:

Do I still have to first manually connect to network in the GL GUI (>Internet)? - seems answer is yes.

Do I need to disable auto scan and reconnect under repeater options in the GL UI? - I would think yes if Travelmate is enabled. And does this setting become redundant anyway if GL Health has been deleted?

Do I need to save the station(s) in GL UI?

@sos_sifou - re. point 7 - others have reported same problem with 3.13 but I can’t re-produce any of the OpenVPN problems

Why would we need to install an additional package (travelmate)? WiFi repeating works fine on the ar-300m and it’s supposed to be a feature in the ar-750s. Surely it should work without having to mess around with installing anything?

It’s an advertised feature that doesn’t work. It needs to be fixed in the stock firmware.