AR750S ZeroTier Setup Guide?

anyone know how to setup Zero-tier on the ar750s I installed the pkg. but how do i configure it? i an trying to connect two Lans into one VLAN

I was able to do it on my AR750S by doing the following.

  • install zerotier package
  • edit /etc/config/zerotier add zerotier network id and change enabled to 1
  • reboot
  • in luci create ZT0 interface, unmanaged and mapped phyical address custom ztqu3bvy4n (check your exact address for Zerotier with an ifconfig from CLI), save and apply
  • edit the interface and create new VPN zone Zerotier, save and apply
  • go to vpn zone, leave as accept, accept, reject
  • I turned on masquerading and MSS Clamping, and added lan and wan to both source and destination zones, save and apply.

After that I was able to ping to and from other devices in my zerotier network.

I then set one device as a bridge and added the route in the zerotier portal and could access my lan.

  • Create an account in ZeroTier Central, then create a Network on it
  • Install ZeroTier on AR750S
  • Edit set enabled option to 1, and set join to your network ID in the configuration file /etc/config/zerotier
  • Start ZeroTier in AR750S via /etc/init.d/zerotier restart
  • Stop and remove MWAN3 package, which will change the route decision. The command you need to execute in AR70S ssh console: mwan3 stop && opkg remove mwan3 --force-depends
  • Configure the firewall, add those lines into /etc/config/firewall
config zone 'vpn_zone'
	option name 'zerotier'
	option input 'ACCEPT'
	option forward 'REJECT'
	option output 'ACCEPT'
	option device 'ztwdjh372k'
	option masq '1'
	option mtu_fix '1'

config forwarding
	option dest 'zerotier'
	option src 'lan'

config forwarding
	option dest 'lan'
	option src 'zerotier'

Please note that the device name should match with your own interface name(you can check it via ifconfig). The ZeroTier interface is begin with “zt”, so you also can use regular expression, such as option device ‘zt+’ .

Finally, restart the firewall to put info effect. /etc/init.d/firewall restart

1 Like

I need to ssh into the router so i can enable zerotier to 1 correct?

Can I bridge my Wireguard interface with a Lan port on my ar750s have have a client connect? with wireguard? or is there a better way of doing this?

Above I write is in command line, so you have to ssh to the router.

The WireGuard doesn’t support bridge.

Thanks I will do it the ssh way.

when I use wireguard i get a 10.0.0.x address and my glinet router address is 192.x.x.x does it matter if i am trying to connect clients. Do i need to be in the same IP range??

can someone write a guide how to do this step by step I kind of suck at networking…

You’re in the right way. The subnet of the router can’t be the same as WireGuard.

You have two routers. Using one of them as client, another as server, you can access server’s LAN from client’LAN by default.

But if you want to access client’s LAN from server’s LAN, you have to ssh to the router, add your client’s subnet to /etc/config/wireguard_server, it looks like:


Finally, you should restart WireGuard server in admin web page.

It should be simple to do.

I can now login into both of my routers but i cant see any clients in my server side router tables does that matter???

Maybe your client has enabled firewall? If you can access the router, and the configuration is correct, you can access the LAN device as well.

Kyson-lok, I followed your instuctions setting up zerotier, but it seems to work only on the lan (physical cable) connection but not the wireless connection. When my computer is connected by wire to the Slate, I can browse the web, but when it is connected by wireless, I am not able to browse the net. Any clues? I tried to add the Zerotier device to the br-lan in the physical interface, it does not seems to help.

Kyson-Lok, actually, I am encountering the upstream wifi connection drop issue as described on the other threads since I cannot even ping any address, local or the web.


Don’t know what happened, I re-flashed the latest released firmware, did a reset and now seems to be working. Will have it run for awhile and see if it stays connected.

So this issue had been solved, right?

Yes, currently it is working!! Keep my finger crossed. Thanks for asking

This is the part that caused me a problem. When I performed these commands, the firewall wouldn’t start because it was looking for this. I reinstalled MWAN3 and the firewall started. From the outside, I can ping the local address of the router, but not any other clients on the lan.

Any suggestions?

I’ve followed this guide and I have a connection to ZeroTier and get an ip. However I’m trying to setup like this:

I’m guessing something needs to get changed but I’m not seeing it. What would I need to change to get this setup to work per the link above?