AX-1800 Flint 5Ghz Wifi is Terrrible!

I would like to know if I am the only one having a terrible experience using the 5 Ghz band on the Flint using the latest stable firmware…? Connections keep dropping, signal is not good, overall it is a terrible experience.

The 2.4 Ghz band seems to be working fine however. Anyone else having the same issues as me?




Hi there @MeWhy , open the LuCi panel using the “Advanced” settings. Navigate to the wireless settings, change the 5GHz settings and make sure that it uses the correct region.

Like @Riktastic mentoided check the settings in luci.

Besides country, for 5ghz you can also try to set the mhz higher to 80.

Also for troubleshooting wifi especially in a high populated area you can use a app for android called wifiman, this allows you to see how much your wifi overlaps with other wireless channels.

You can also try to disable the krack checkbox.

If all of this has been checked, and still issues please sent us a log and the additional wireless, dhcp, network configuration.

It could also be just the dhcp server crashing.


Nice. I’ll throw a F/OSS option out for us, too:

1 Like

As a follow up, it tried many of the suggestions proposed in this thread. The country code was checked and was correct, WiFiman was downloaded to verify any potential problems etc. I tried the latest beta firmware, I tried 4.4.6, 4.2.3. / The only firmware that is rock solid regarding the WiFi signal is 4.2.1.

So here it is, I’m back on 4.2.1 since it is the only firmware that gives me a stable internet connection. I forgot to mention that I’m also using this router as a “VPN router” using Wireguard. If I were to guess, I would say that from 4.2.1 to 4.2.3 and beyond, the WiFi driver changed. I read a previous post regarding someone else who had to do as I did and revert back to 4.2.1. This is not normal.

Hopefully the Flint2 won’t be as buggy!

1 Like

Has there been such an impacting change as @MeWhy suspects? I see the changelog states there was a SDK rollback in 4.2.3 fr v7.6.7.0 to v7.6.6.1.

1 Like

I have WiFiman running right now. Using firmware 4.2.1, my router is still using channel #36 using the 5180MHz/80. So the router no matter the firmware is using the same channel and frequency so it is not a congestion problem… My best guess would be a driver / software issue… Hope this could help. WiFi Signal on either 2.4 and 5 GHz is rock solid since moving to 4.2.1. The problem never was with 2.4 Ghz by the way, it always was with the 5Ghz band.

Not sure if it matters but my WiFI configs where using WPA-2 and WPA-3 on the 2.4 band. On the 5Ghz band I was only using WPA-3.


only 2 things what I could think off is have you checked this setting?

or country/dfs, for me it works good and I use 4.5.0 beta1, please post logs :slight_smile:

Can you try downgrade the wifi firmwware according to this post?

Pls note, it is the wifi firmware, not router firmware.

1 Like

v7.6.7.x is for mt3000.
firmware 4.2.1 and 4.4.6 is the same wifi driver for Flint. Do you use repeater?
and maybe the radio environment changes in your place @MeWhy

Thank you everyone for helping out, it is much appreciated. This is a little update on the situation…

After spending many days and weeks pulling my hair out trying to figure out how to fix this issue, I think I might have found part of the problem…

As you know I been changing firmware going up and down trying to find something that would give me a stable 5GHz connection. All in all, some 4.x firmware where better than others but nothing rock solid. I decided to upgrade once again to the latest 4.4.6 version. What I did next was to remove WPA-3 from the settings and only use WPA2-PSK on both the 5Ghz band and the 2.4Ghz band. That seems to have fixed the major issues I was having. I also manually configured the 5GHz band to use channel 161. All in all, as of this morning, my 5 GHz signal has been rock solid. It seems that some adapters do not play nice with WPA-3. I will keep you all posted and see if this stability last. I’m also wondering how my future Flint2 will handle this with the default options enabled…

Thanks again for all who have tried to help me fix this. An update will follow in a weeks time.



Cripes; this isn’t the first time I’ve heard of WPA3 being the root cause. I wouldn’t worry too much re: WPA2 v WPA3 if you’re looking for ‘top notch’ Wi-Fi security; Dragonblood renders it all moot. It’d be better to setup up WG + PSK on all devices in the subnet.

1 Like

I have also noticed the wifi glitches on 4.x tend to be less bad with WPA3 disabled :neutral_face:

Thank you so much for this. I have been troubleshooting wifi instability for a while now and this seems to have cleared things up for me. I was having very cyclical ping drops, about every 10 seconds or so, on multiple clients (windows, ios, android) and have been trying to figure out what was wrong. I changed this setting and it seems to have cleared my issue. Using a GL-X3000 Spitz on 4.4.8 (4.4.6 had this issue as well).