AX-1800 - Luci - br-guest does not appear in devices list


I’d like to configure one of the (v)LAN ports on my Flint to be in the guest network.
Unfortunately, if I go to Network/Interfaces/Devices, the Bridge for the guest network isn’t there, so I cannot map any port to it.

I know I can create a new bridge and assign the same functionalities as the guest network to it, but in that case, I would lose the configuration and monitoring from the gl.inet webUI (which I need for some less tech-savvy users).

Any workaround?


In fact, all you need to do is edit Guest in Network/Interfaces/Interfaces and select the LAN port you want in the device. Then edit br-lan in Network/Interfaces/Devices and delete the LAN port.


Note: The gl.inet webUI is not compatible with this case and some unexpected errors may still occur. For example, the guest network logo cannot be displayed on the network cable in the picture above.

Thanks for your answer. I already tried that, but if assign an ethernet device to the guest interface, I lose wifi connectivity. The LAN port I assigned is working, but no more wireless connection.

I checked the wireless interface properties, it’s still assigned to the guest interface, but I got no more DHCP nor connectivity when I connect through wifi.

As you can see below, the bridge seems to disappear as soon as I assign an ethernet port.



Anyway, that’s no big deal, I’ll create a new bridge interface for the wired guest network, which will be different from the wireless guest network. This is just for some clients to get internet access, nothing more.

If you want to use both the network port and Wi-Fi on the guest network, then you follow these steps.

  1. create a bridge device named br-guest and add eth3 to the bridge ports
  2. delete eht3 from br-lan
  3. Edit the Guest interface, remove the bridge configuration, and check br-guest in the device options
  4. Find the guest Wi-Fi in Network/Wireless and turn off the Isolate Clients option

The /etc/config/network configuration file should like:


Thanks, that worked fine.
I just deleted the guest interface first, otherwise I couldn’t create the br-guest device because it was already existing.
And then, of course, reassign the guest interface to the firewall zone.

Hi @pinus, wondering if you could post some screenshots from Luci on how you did this exactly?
And how did you delete the guest device? br-guest is not listed for me as well.

@yuxin.zou Is this also possible on a beryl ax?
I have the same problem and followed your approach to the letter but with vlans, but it does not work. I opened a post for it but maybe you can answer it?