B1300 Mesh "issues"

Am having real trouble with Mesh on 2 X B1300

Both running 3.024.0606

The big problem is when I first got them I managed to mesh first go. Then I reset everything to try something else. Now I can’t get them to mesh at all.

Master -> press mesh button , wait for first 5 flashes, then when faster flashing starts release button
Slave -> press mesh button , wait for first 5 flashes, then when faster flashing starts release button

The master node gets a solid mesh light but can’t get the slave to get a solid mesh light.
All I get is a mesh of one unit :frowning:

Lots of solid and flashing mesh lights but not two solid mesh lights :frowning:

Most common is I get a solid mesh on the master and flashing on slave, then the master starts flashing and I end up with two flashing (medium speed) mesh lights.

Have tried firmware reverts and uboot loads. Have tried swapping physical units (master->slave, slave->master)

Thoughts?

BTW there’s an issue with the Uboot load screen too.

While the uboot UI has some problems, it the router really flashes the firmware, it is fine.

About mesh, I see there is “cable” displayed in the 2nd node. When you pare a leaf node with main node, do not connect cable to the leaf node. After mesh you can connect a cable for backhaul.

If the above does not fix your problem. Pls let me know.

@alzhao That is the master node not the slave node.
No cables in the slave mode :frowning:

I can see the master node swapping between wireless and mesh in the Admin UI but only the master node itself.

I either get solid on master and flashing on slave or


(Music purely coincidental :slight_smile: )

Tried changing wifi channels. I think I can see the mesh wifi coming up too (ssid strange characters)

If mesh pairing ending in master solid but slave flash, you can push mesh button again at both side. No need to do reset. If that doesn’t work, you can try push mesh button more than 10 seconds to very fast flash to quit mesh mode and do pairing again.
Master node won’t be flash always unless the wan cable is not plug in, that case it’s also as a slave.

@hansome

Thanks for that, but I’ve tried everything I can think of :frowning:

  1. press till very fast flash so both forget mesh/mesh setup on both units
  2. firmware reset both units
  3. uboot and reload software on both.
  4. Swap physical units as master slave

Given what you just said about master node flashing I might try a different network cable and/or upstream router. Think I might have originally had the AR750s attached when it did work and these last few times I’ve been using MT300N-V2 (attaching mesh to a WISP router) .

My thumbs are getting sore :rofl:

Ok. Have reset both nodes, changed source router, source router mode (wds, repeater, wisp) and network cable and no go.

Master solid, slave flashing and then after a little time both master and slave flashing :roll_eyes:

Still can’t get this going.

What triggers the master node setup when it has a plug in the WAN port ?

Is it:
a physical (inactive) plug in the WAN port?
an active (link) plug in the WAN port?
internet access via the active (link) plug in the WAN port?

It has to have a active (link) plug that the router can detect. Not necessary internet. But cannot be just physical.

@alzhao Ta . When my thumbs have had a rest I’ll do some more experimenting :joy:

Should I try posting some logs or something next time I try to get the mesh established? Would that help? How do I save logs if it does? :blush:

For the logs you need to ssh to the router and use command to generate log. Then get it out using winscp or scp

The command is
logread
dmesg

@alzhao

Thanks. Will it assist in diagnosing the issue?

I don’t know. @hansome should know.

@limbot hi, please show info following command:

uci show gl_son
iwconfig
ps w
( echo 'td s'; sleep 1; echo 'q'; ) | hyt
wlanconfig ath11 list
hostapd_cli -i ath11 -p /var/run/hostapd-wifi1 wps_get_status

you can send me mail at handongming#gl-inet.com
Thanks

Incoming :slight_smile:

Downgraded back to 3.022 as Marin said he couldn’t get mesh to work with 3.024 but no difference :frowning:

Hi limbot,
The mesh pairing is implemented by WPS, I checked your log. It says you don’t push the slave’s mesh/WPS button to trigger WPS communication, like
PBC Status: Timed-out
Last WPS result: None
If pairing fail, push both master and slave’s mesh button for 5 second.
You can use
hostapd_cli -i ath11 -p /var/run/hostapd-wifi1 wps_get_status
to confirm again.

@hansome

Ok, thanks for reply.

Mmm, so confirming process.

Press the mesh button on both units. Wait for first 5 slow flashes, wait for first couple of medium flashes an then release mesh button on both units…

Failing this is there manual entry changes I can make via WinSCP that will setup the mesh ?

Not ok with WinSCP. The key is passed by WPS and then consecutive settings. You can push both unit again. No need other operation.

@hansome

OK, finally got time to play and…

Finally !!!

Don’t know what I did differently, held tongue in right direction or something? :smile:

Thanks for assistance!

My setup because I don’t have access to the main router. WISP mode Mango with WiFi off connected to Master node :blush:

Do you think I could run the Mango off the USB port of the B1300?

Speeds just as good as connecting to the “source/master” router at both master and slave node locations :slight_smile:

You should be able to run the Mango from the b1300. I’m running a Ar750 off my b1300 without any issue. In fact I also have a USB camera connected to the ar750.