B1300 Mesh

This is yet another thread on mesh mode for the B1300.

In short, it is getting closer, but in my experience, it is not well enough documentation or logging to give me a lot of confidence. That said, I would say it is working.

Despite advice to the contrary, I got nowhere until I did a full factory reset of both the Master and all of the Clients. I left the Master in its default mode, not changing the password, the SSID, or the subdomain, i.e. left the Master at

I was able to pair the Clients, one at a time. It is important to clarify that one should release the Mesh button once the mesh light starts to go 2x faster. You should have released it well before the mesh light begins flashing rapidly. It took 3-4 minutes for each Client to eventually get a solid Mesh light and show up in the Master’s Mesh tab. (Note, in further testing, discussed in the next post, the Mesh light was not always consistent.)

[As an aside, it might be helpful if there is a bit more user-visible logging to see the progress of setting up the Mesh. Likewise, a key on what the various flashing speeds of the Mesh light would be nice.]

Everything above thus far was with all four of the B1300’s a few feet apart in the same room.

Then I moved each of the clients to their semi-permanent placement around the house. Eventually, I was again able to see all of the clients in the Master’s Mesh tab. At this point, I changed the Master’s password and SSID. After that, things got a bit fishy.

Some clients, the mesh light never went constant again. Instead, they would slowly blink.

Also, I tried plugging other devices into the LAN port of the Clients. I saw inconsistent performance of these devices.

I don’t think I can keep my system in Mesh for much longer before my family members start rioting. I’ll likely switch it back in a few hours, but if you want me to try something first, please let me know ASAP.


I have reset the entire system, to see if I can repeat the experience. I think that things did work pretty well, after I did the factory reset of all devices and confirmed they were all using the same firmware (3.104).

Confirming that the only Ethernet cord was connecting my Master WAN port to my cable modem, I pressed and held the mesh button on the Master. The mesh light flashed 4 times at a rate close to once per second. Starting with the 5th flash, the light started flashing 2x as fast, approx 2x per second. At that point, I let go of the mesh button.

When I logged into the Master (wirelessly, with my computer), I could see that the Wireless tab had changed to a Mesh tab, and the Master was shown in the Mesh Clients, near the bottom of the Mesh tab.

I then went to one of my clients, which was booted up after a factory reset. I held the Mesh button and released just as described above with the Master. After 3-4 minutes, the first Client showed up as Sub Node 1 on the Mesh tab of the Master’s config page (at However, the mesh light on the Client never went constant-on, instead blinked slowly.

I have added a second Client sub node as well, exactly as described above.

I have also changed the SSID, as well as plugged some devices into the LAN of the sub node. This mostly works.

The one thing that still disquieting is that the Mesh light does not stay lit. Also, sometimes I see some dependencies in the Master’s config page, e.g. a node will show up in the Clients tab, but not in the Mesh tab, after expanding all of the nodes.

My suggestion is to provide a bit more explicit advice to us users on how to log the Mesh creation, status, and so forth. A solid Mesh light is hard to come by, even though things seem to be working (although I have in no way stress-tested my system).

Hopefully I have added a few more details in this post to help others get to this point.


Yes documentation is very lacking, besides press the button.

I’ve been mucking around with my B1300 mesh after moving into a new house and here’s what worked best for me FWIW (now running a 4 node mesh)

  1. Reset master node
  2. Connect master node via WAN port
  3. Setup master node to get a working internet connection
  4. Scan surrounding WiFi channels to find best channels to set both the 2.4 and 5 Ghz channels to
  5. Set the WiFi up on the master node to match appropriate channels as per 4 above
  6. Also pay attention to bandwidth (20,40,80) depending on environment
  7. Reset 1st slave node
  8. Place slave node near the master node
  9. Press the mesh button on the masternode until the second faster flash and release
  10. Press the mesh button on the slave node until the second faster flash and release
  11. Wait - this appears to take a completely random amount of time to get a proper mesh connection. Often more than the state 3-4 minutes above.
  12. You can go tto the master node @ and watch the status of the mesh ( doing browser refreshes) , you should eventually see wireless change to mesh on the LHS menu and you should see node 1 appear under the mesh on the mesh page. Wait until you get solid green on both nodes.
  13. Change the mesh name and password to what you want it to be on the mesh node on the master node
  14. If you have additional nodes, reset them, bring them close to the master node and slave node
  15. Repeat steps 9-12 above until you see node 2, node 3 etc and solid mesh lights
  16. Place the nodes where you want them
  17. Find the optimal position for the nodes so that all nodes show connecting to the mesh (solid led)

Note I have previously had issues where the slave nodes have a flashing mesh light however they still seem to work fine. Can check to see if your mesh status on the master node shows clients attached.

As I say, don’t know if tis helps but every little thing hopefully works towards a whole solution :slight_smile:

1 Like

Yes, it seems like our experiences align. Perhaps the quickest way to summarize is: You can get a multi-node mesh network using instructions above, but you should not pay too much attention to the mesh light.

Again, I would encourage GL-inet to add some additional logging, or indications in the config page, to show what is going on.

Thanks for the write up! I also spend quite some time to figure out a reproducible setup. Had a lot of notes, but couldn’t really figure out a pattern. Same issue with the mesh light as you reported. When mesh is set up, it mostly works fine, but sometimes performance feels weird. Maybe around “hand over” when moving through the flat. I guess we are all fine testing around different things, but lack of guidance or logs is a bit frustrating. I mean, in the end we like this project and want to support the idea of truly open-source and tweak able routers :slight_smile:

Yes, thanks for this write up! Helped!

Got “Main node” and “Sub Node 1”.
But same here, devices don’t seem to switch to nodes. Or randomly/not- fast enough/not predictable.
Hard to debug.

Also it looks like the Sub node is still broadcasting the default “GL-B1300-xxx” network and I can connect to it using the default password.
If I connect to the Sub node via cable (Wi-Fi turned off) I just the the settings I see on the Master node as well. And I see my cable connected laptop in the device listing of the Sub node.
The “Mesh” light on the Sub node isn’t solid all the time though. It’s more or less 3 seconds green, 3 seconds off.

Are the mesh lights solid if you have the two close together?

So looks like one of the routers has an issue. We replaced it with a new model and after that the mesh works flawlessly. Both lights solid green. Good connection.