Beryl AX Hotel Wifi - No IP


I’m trying to connect my new Beryl AX to my hotel’s Wifi but I am not having any success. Details:

  • I’m at the Mawson Lakes Hotel, Adelaide (Australia). The hotel is using these guys for their wifi system: Internet Gateway | GNT Asia Pacific Pty Ltd.
  • The Beryl AX connects to the Wifi but is not assigned an IP. All I can see is a BSSID. I’m not able to access the captive portal. I’ve attached a screenshot showing this.
  • The Beryl AX is running 4.4.5.
  • I have followed the captive portal guide (disabled DNS rebind protection, disable VPN/Adguard, copied the MAC address from my iPhone which connects without issue). But since I am not assigned an IP I am not sure these would have helped anyway.
  • I factory reset my Beryl AX and this did not change anything.
  • I just bought the Beryl AX and this is the first hotel I’ve tested it at. I tried it at home before leaving and it connected to my home network without issues.
  • My laptop (Dell Precision 7650 w/ Windows 11) and my iPhone XR are able to connect to the hotel Wifi without issues.

I would appreciate any help, I have read a bunch of guides and forums and have not been able to make any progress.


In my experience, I most frequently had this type of issue when I was barely in range for wifi. Could that possibly be a possibility?

Hi groentjuh, I’ve tried three different spots in the apartment hotel each with the same result. The place it’s in now has strong reception on my iPhone. I’ll try some other spots though and let you know.

Edit - tried the other side of the bedroom (strong reception on phone and laptop) and the bathroom (why not?) - no change, no IP.

It wants you to sign into a webpage that is being blocked by the firewall/settings on the router. turn off any custom DNS, adguard, VPN, and connect. Also you may need to connect to 2.4ghz then can connect to the 5Ghz

Have you seen this thread (this forum are so blooming difficult to navigate and search and I wish these questions and answers could all be lumped together into some more useful categories)?

1 Like

Ask the hotel which security protocol they use for wifi and check compatibility.

1 Like

@K3rn3l_Ku5h I have tried disabling DNS, Adguard and VPN as mentioned in my first post (I even factory reset the router!). I had no success trying different combinations of 2.4 and 5 GHz.

@shivadow What do I ask the hotel? Are you referring to WPA2 - because if so this network is unsecured.

@Almahadeus This worked - thank you for this thread! If anyone else is wondering I did the following:

  • Cloned the MAC address of my laptop and changed the Beryl AX hostname to my laptop (I was just trying everything, not sure if this was related)
  • Went into LuCI and set the WWAN interface to have a static IP configuration that matched what my laptop was assigned via DHCP.
  • Set the DNS Server manually in the gl.inet interface to the hotel’s gateway (

Screenshots below. I note that the subnet mask was - is this unusual? Thanks again for your help.

I have split the screenshots between posts as I am restricted from placing multiple images in one post as a new user.

1 Like

1 Like

1 Like

Very glad that it has worked for you and all credit goes to @terry23 and @wcs2228 for coming up with the solutions.

Also appreciate your screenshots for other users to use as a reference. All the best.

1 Like