Beryl Ax issue with USB Tethering


I have a Beryl Ax. For a while now, I’m having an issue with the USB tethering mode. As I don’t have a good internet connection at home, I subscribed to a 5G unlimited plan which gives me around 300 Mbps of speed. I am using USB tethering with an Android phone.With USB tethering, I used to get at least 200 to 250 Mbps. However, suddenly for the past ten days, I’ve been capped at a maximum of 2 Mbps. I thought it was the operator throttling my speed, but that’s not the case because when I connect the USB cable to my PC, I get speeds between 300 to 400 Mbps. And direct speed test from the phone indicates atleast 400 Mbps speed.

I upgraded to the beta or snapshot version of 4.2.2, but the problem persists. I even downgraded to version 4.1.3, but the issue remains the same. I even resetted the device to factory settings, but it didn’t help. I don’t understand why my speed is suddenly limited.

Thanks for your help.

Hi,Can you please share system logs of the MT3000?

You can try following this link and setting the ttl to 65

Provider has detected what you are doing and is throttling it. This is common. You can try adjusting the TTL as suggested but that may only be a partial or even temporary fix if the provider is doing DPI (Verizon has started this pretty aggressively…)

Sorry, I was out of town. I will send it to you tonight. Thanks

Tried already this method. There is no change. But the command was little bit different. I will try your link and check

I thought it was the case. But my provider is the only one in France accepting sharing a connection with a router. So it’s strange (15.1 KB)

Please find attached the system logs file. Thanks

I don’t think that this is provider issue. Tried with 3 different SIM’s from different providers. The result is not better. I can get maximum 3.4 Mbps.