Beryl AX repeater connects to hotel wifi, no internet access

Model: GL-MT3000 Beryl AX

Version: 4.4.6

Hello, I’m trying to set up my Beryl to repeat a hotel wifi with a simple captive portal. I have tried cloning the MAC of both my phone and laptop that both have been whitelisted on the network, the beryl connects to the hotel wifi and seems to get an ip address however any devices connected to the beryl wifi do not have access to internet no matter what I try.

Things I’ve tried:

DNS is automatic and I’ve also tried setting the DNS to the hotel wifi’a gateway address.

When connected I tried setting the manual IPv4 to my laptop’s IP on the hotel wifi

VPN is off

Tried doing a factory reset

Could you please follow the steps „General troubleshooting“ in this post and get back with the results?

Thanks in advance!

Oh, here we go again. Another day and another drama about connecting a blooming Beryl to a hotel WiFi. When will people realise that these “travel” routers are not fit for purpose?

I wouldn’t say that travel routers are not suitable. The problem is rather that the security measures in hotels are (fortunately!) getting better and better, and you sometimes need to have in-depth network knowledge to set up a repeater correctly.

Nevertheless, it’s nice when people ask questions here - with every question answered, the knowledge in the community increases and the cross-references improve. This way, even readers who don’t post anything can benefit.

1 Like

The massive caveat in what you have said and with my extensive experience with this issue is that other travel routers from other manufacturers like TP-Link, Netgear and Huawei (let alone other more primitive network clients like Firesticks and older phones) tend to work quite well and with minimal fuss when compared to the dreadful GL.iNET lot.


Hello thanks for your help,

-I have reset the firmware and factory reset
- times out and has nothing returned
-DNS resolution comes back at 52.41.83

here is my log
beryl (29.2 KB)

Love the positivity, thanks for stopping by and dropping your wisdom

Pls don’t set the dns and manual IP.

When you do mac clone, can you not using the same mac address connect to the router or hotel wifi?

For example, when you clone your phone’s mac to the router, you can this:
Turn off your phone’s wifi and check using your laptop. Or you can set your phone to use private mac address so that it will use another mac address to connect to the router.
Then try the following in both your laptop and router.


If you have whitelisted your mac address and it get IP from the hotel, there should have no portal authentication needed.

Yes I don’t actually believe it has anything to do with security measures.

The Beryl AX firmware is very buggy. The 5ghz and repeater mode are not stable. There is also issues with DNS, VPN and firewalling!

I feel that Firmware 4.5 is getting closer, but it seems inet are in no rush to resolve the many issues.

They release firmware, take it down, reply again saying oops we uploaded it again, it just doesn’t feel very professional.

They have already released new devices with 4.5 firmware and left the Beryl AX on old firmware.

Unfortunately I cannot recommend gl inet and while I love the idea of the device, it causes me more issues than it should, there are old more stable options out there.

1 Like

Hardly stopping by my friend. I have been banging on about this issue since inception of GL.iNET and has unfortunately lost any positivity that these issues might be resolved one day. Here is only just one example of one of my threads probably way before you had ever heard of this company:

Well, you have to understand that you are not really allowed to bring your own router to any other network than the one you have under your control. It might be tolerated, but mostly the network admins will try everything to make it as difficult as possible.

This isn’t the fault of the router manufacturer - it’s just how IT security works.

Your post about “IT SECURITY” just made me laugh a bit remembering how my Beryl AX failed miserably in repeating a WiFi signal while I was camping on an old farm in middle of the English countryside last year with basic WiFi that had poor signal when I wanted to leave the Beryl in the middle. Bought a TP-Link on the day which connected as soon as it was out of the box and turned on. Feeble excuses for false advertising and poor functionality.

1 Like

I’m not saying that the GL.iNet products are perfect. They are not. But you have to understand that the use of a repeater (or another router) within a network is not normally wanted by the network owner.

If this is a farm somewhere in the furthest corner of Scotland - then the fault presumably (!) lies elsewhere. But with large hotel chains or professional companies, it will always be more difficult.

I have fewer problems with my Opal than with the Flint - but in the end it always depends on the situation and your own knowledge.

I’m really interested to know what “IT security” you are talking about. 99% of hotels uses basic open wifi with a captive portal.

I think you are making excuses for gl.inet for no reason, I haven’t seen this level of firmware instabiilty in any other device on the market currently.

1 Like

You are right that the firmware isn’t stable or has sometimes bugs in it. But that’s a con of having a system with rolling releases like OpenWrt in that case.

Indeed quality and testing is an issue which should be addressed. But on the other side there are many user who are happy with the devices.

Might be an issue with the advertisement as well since many users don’t understand or know what it means to have an fully OS.

If you aren’t using it for VPN then why not just connect directly to the hotel router? You aren’t really gaining anything by adding your own router. Its unrelated but another option is to buy a SIM card with unlimited data and set your phone as a wifi hotspot (check network provider rules about tethering though as some companies block it)

Of course, I’ve got like 3 VPNs + multiple devices so that is the entire point of this device…

I think what you are also saying is that this device is not fit for purpose?

1 Like

My response was for thedeitz as he mentioned no VPN was in use. You seem kinda angry :face_with_diagonal_mouth:

Did you follow all steps on this page:

I wish the GL-iNet gui had a page listing those settings, so you have 1 spot to see what might be causing captive portals to no load. Add to that page an option to set TTY and maybe many of these kinds of issues are solved.

As for the “look how bad GL-iNet handles this”. These are pretty advanced routers with also sometimes safety in mind. An example of this is DNS rebinding protection being present and i believe being enabled by default. That might actually screw over captive portals, but is fine protection in nearly all other situations!

Advanced features such as adguard, VPNs frequently aren’t possible on those other travel routers, but when used they might cause issue for a captive portal to load.

1 Like

My goal is to use a wireguard VPN to my home for all my devices