Beryl AX repeater connects to hotel wifi, no internet access

Yes, that was the first thing I looked through when troubleshooting, I have connected to a captive portal with this device before, just have struggling with this wifi. It’s a basic captive portal with no login or password required and it’s not a large chain fancy hotel either just a basic inn. I am starting to question if I should return this, I got an opal for my dad and he had no issues connecting to a portal at a resort in Mexico

Which TP-Link device would you recommend then?

For lightweight travel I use:

and for my camper, I have:

For VPN, I am now more reliant on setting it up on individual clients (phone, laptop and firestick) as these routers do not support VPN out of the box. If I am desperate for a VPN on router, then I carry the Mango and tether it to my TP-Link as well.

I have to add that I used to be a massive fan of GL.iNET routers but it has been a while since they appear to have completely lost the plot producing new models every few months (I think that they are even looking at introducing one with a photo frame!!!) before fixing their firmware and with some devices going EOL before actually functioning adequately (Brume v1 as an example). They had the market for “travel” routers but then these started to be unfit for purpose and now they are tapping into “home router” market with buggy devices that cannot be reliably used as home routers and they appear to have completely lost it which is a huge shame.

1 Like

My Flint home router has always worked okay and any issues have been easy enough to fix with zero knowledge of technology. They do indeed need to focus on refining existing models rather than producing endless new ones

1 Like

My (mental, now come to think of it) history with experimenting with GL.iNET (and that is only from Amazon UK with other devices bought directly from them and from other retailers as well:

Have not and will not order anything after the GL-AXT1800

1 Like

Wow, you must have a small warehouse worth of devices after all that purchase history. I honestly think it would be worth giving the Flint 2 a try since it will be their current most powerful model (I think) and it has network acceleration which the AX1800 doesn’t so you will get better speeds.

I intend to try one myself but probably in a few months time once the initial launch bugs are sorted and hopefully the price comes down a little.

@hansome Give this guy a free Flint 2 for being such a loyal customer :stuck_out_tongue_closed_eyes:

2 Likes

I checked the log and found you upgraded the firmware to 4.5.
You get an IP of 192.168.98.x but the gateway and DNS are 192.168.96.x.

How do you set the static IP for the repeater, is it working with DHCP and maclone? @thedeitz

Sorry for the inconvenience and frustrations you had, could you set up an environment for a remote desk session to check.
@Almahadeus

Thanks @hansome for your offer of help but I am not currently in a situation where I need to use a travel router for repeater/captive portal purposes. I will aim to message you directly if I can in that position again to see if we can set remote access up at that point. Thanks again.

1 Like

I have it all set to automatic if that’s what you are asking

1 Like

This is the exact same situation that I am in right now.
I am in version v4.4.6 Beryl AX device.

I am cloning the MAC address of my phone that’s already been logged in to a captive portal. I can see that the Beryl is getting connected and inside ssh i will get ping from www.google.com

root@GL-MT3000:~# ping www.google…com
PING www.google.com (142.251.220.196): 56 data bytes
64 bytes from 142.251.220.196: seq=0 ttl=56 time=45.321 ms
64 bytes from 142.251.220.196: seq=1 ttl=56 time=67.132 ms
^C
— www.google…com ping statistics —
2 packets transmitted, 2 packets received, 0% packet loss
round-trip min/avg/max = 45.321/56.226/67.132 ms
root@GL-MT3000:~#

But all the devices connected to my Berly AX wont have any internet. I have DNS, VPN, TOR, Adguard Home disabled.

I also noticed that MAC cloning isn’t all that stable. Sometimes after getting it cloned it will get reverted back again.

For this problem i suspect DHCP sending of host names. I think the captive portal is smart enough to also relate the MAC to the host device name. But that’s only my suspicion. Hope this gets a work around and get resolved soon.

What do you mean by „DNS disabled“?
Your devices need DNS to be able to reach the internet.

what i meant to say is DNS is set to auto. sorry

What happens when you ping and nslookup from devices connected to the Beryl?

####### CLIENT connected to Beryl AX PING TRACE AND NSLOOKUP #######

PS C:\Users\xxx> nslookup.exe google.com*
Server: console.gl-inet.com
Address: 192.168.8.1

Non-authoritative answer:
Name: google.com
Addresses: 2404:6800:4005:811::200e
142.251.222.206*

PS C:\Users\xxx> tracert 142.251.222.206

Tracing route to hkg07s55-in-f14.1e100.net [142.251.222.206]
over a maximum of 30 hops:

  • 1 * * * Request timed out.*
  • 2 * * * Request timed out.*
  • 3 **

PS C:\Users\Jxxx> ping 142.251.222.206*

Pinging 142.251.222.206 with 32 bytes of data:
Request timed out.

Ping statistics for 142.251.222.206:

  • Packets: Sent = 1, Received = 0, Lost = 1 (100% loss),*
    Control-C

####### Bery NSLOOKUP #######

root@GL-MT3000:~# nslookup google.com
Server: 127.0.0.1
Address: 127.0.0.1#53

Name: google.com
Address 1: 142.251.222.206
Address 2: 2404:6800:4005:811::200e


Basically DNS is working, but its not routing any traffic.

Got mine to work. I just followed this Router mode doesn't give internet access to connected devices

this can also be helpful Changing TTL in OpenWrt 22.03

1 Like

The iptables mangle directions don’t work for my Beryl AX at 4.5.0 or 4.5.16 (Beta).

root@HarvBeryl:~# iptables -t mangle -I PREROUTING 1 -j TTL --ttl-set 65
iptables v1.8.7 (legacy): unknown option “–ttl-set”
Try `iptables -h’ or ‘iptables --help’ for more information.

(4.5.* is based on OpenWRT 21.02-SNAPSHOT r15812)

Has anybody had any luck with modifying the TTL settings on 4.5.*?

Thanks!
\john

It needs an ipk please run command to install

opkg update
opkg install iptables-mod-conntrack-extra

EDIT 1: Oh! While poking about at unrelated settings my ssh session was disconnected; upon re-connection, “it worked.” That is, iptables accepted the command without error. So, YAY thank you.

However, checking iptables output
iptables -L
shows no chain named “PREROUTING” in the list of 43 other chains.

Is the syntax still valid as of 4.5(.16)?

iptables -t mangle -I PREROUTING 1 -j TTL --ttl-set 65

Thanks!
\john


Thank you for the quick reply!
The command reports that the package is there and up to date:

root@HarvBeryl:~# opkg install iptables-mod-conntrack-extra
Package iptables-mod-conntrack-extra (1.8.7-1) installed in root is up to date.
Updating database.
Database update completed.

I’ll try other things! Thanks again.
\john

1 Like