Beryl not stable

My Beryl running on stops working within several minutes and no WiFi is available any longer

  • WiFi Repeater
  • WiFi incl. Wireguard VPN (connecting to my home) - only 5G
  • Guest WiFi - only 5G
    After some minutes the 2 WiFis disappear - and re-appearing some minutes later again

Using original Power Supply - but also tried others → same result

Should I get a hardware replacement?

Why are you using testing firmware?

Sorry forgot to mention, that I for sure first used latest standard firmware, but was pointed to the testing firmware while reading another thread.
Same behavior on my side.

Are you using as repeater in public places?

If the wifi disappear for some time and appear again, It seems that the repeater breaks then reconnected.

No, it seems Beryl is rebooting from time to time …
This happens even if I am at home and testing with my very stable WiFi as source for Beryl‘s repeater.

If it reboot, the log is gone. We have a firmware that record logs when kernel crash. Sorry to point you to that thread.