Brume 2 GL-MT2500 use 1Gbps as WAN, 2.5Gbps as Lan

By default Brume 2 GL-MT2500 setup 2.5Gbps port as WAN and 1 port Lan 1Gbps.
I want to switch the port around. 1Gbps port as WAN and 2.5Gbps. my ips only provide 1Gbps max up and down, my network is 2.5Gbps and 10Gbps.

accounting article below, 2.5Gbps WAN port can be change to to LAN:
Change WAN to LAN - GL.iNet Docs 3 (

However, how would I setup 1Gbps LAN port change to WAN?

@K3rn3l_Ku5h just recently posted some translated instructions that were recommended to swap the LAN and WAN ports. It should work for your model too.

Thank you for the swift response. I will try it out tomorrow when no one is using the internet and report back here.

I’ve tried your method, and it works on Brume 2. However, since firmware 4.2 and 4.1.1, labels on LUCI interface were changed:

  1. Enter LUCI from Admin Panel → System → Advance Setting → {ipaddress}/cgi-bin/luci
  2. type in admin password (same as Admin Panel)
  3. in LUCI select Network (tab) → Interfaces (scroll down)
  4. on Interfaces window locate WAN (icon) → Edit (click button)
  5. on Interfaces >> WAN window, under General Settings → Device (scroll down) → eth1 (select, default is eth0), click Save (green button, bottom right on current window)
  6. back to Interfaces windows click next tab label “Devices”
  7. on Devices window locate br-lan (icon) → Configure…(click button)
  8. new window open as “Bridge device: br-lan,” under “General device options” tab → Bridge ports (scroll down) → uncheck eth0 and check eth1, click Save (green button, bottom right on current window)
  9. back to Devices windows, click “Save & Apply”
  10. wait 30-60 seconds, switch ethernet cable from ports label LAN 1Gbs to WAN 2.5gb. enter to your ip admin panel. Now we have 2.5Gbps LAN network, and 1Gbps WAN network

Credit K3rn3l_Ku5h
GL MT-2500 LAN and WAN port swap and switch option missing - Technical Support for Routers - GL.iNet (