Brume 2 or Beryl AX3000 as an (always-on low power) AdGuard home server

I have a Beryl AX3000 and would like to add it to my existing network as an AdGuard Home server (no routing function).
My current router is a very powerful mesh router with one node and my whole house is covered.
My current network is at with my current router being at
I tried the following with no success.
Reset the Beryl’s firmware, plug the Beryl’s WAN port into a LAN port of the current mesh router.
Set the Beryl network mode to access point.
Give it a static IP of both on the Beryl and the Mesh router.
Turn off the Beryl’s radio.
Reboot the Beryl.
After reboot, the Beryl comes back up, shows that it is still in AP mode but no longer has the option to see or select AdGuard Home or even any VPN option.
What would be the proper way to achieve the goal.
I wouldn’t mind getting the Brume 2 as well as it has an explicit « Bridge » mode.

I was looking at the reviews on Amazon and found the following review from a user:
« I’ve been able to shift those services to the Brume 2, which sits between my Xfinity modem (in bridge mode) and my eero WiFi router
This greatly simplifies my setup and requires less maintenance. AdGuard works just as well as Pi-hole, and having a GUI interface for Wireguard administration is a plus »

I wonder how that person was able to achieve « my » goal as I was told in this forum that bridging would disable DHCP and DNS (needed for AdGuard Home)

Thank you.

I have my GL-MV1000W running as a standalone AdGuardHome DNS server and not as my main router. When I get around to it, my intention is to replace it with my more powerful GL-MT2500 Brume 2.

You can actually set up a GL.iNet router as a LAN-only server, in Router mode without connecting the WAN port and only connecting the Ethernet LAN port:

Make the appropriate adjustments to the IP addresses in the procedure and turn off wifi on the GL-AX3000 Beryl AX, then set up AdGuardHome.

I do not work for and I do not have formal association with GL.iNet

Just turn of all radios, connect LAN of main router to LAN of Beryl and set the DNS of the main router to the LAN IP of the Beryl?

The standard AdGuardHome implementation on GL.iNet routers will show “localhost” in its Query Log.

In order to show the actual client IP’s, I also made the changes in this post so that AdGuardHome listens for DNS requests on TCP Port 53, instead of dnsmasq listening:

DHCP on your main router has to assign to client devices the IP address of the Beryl AX as the DNS server.

Just tested my configuration.
If I leave the Beryl on router mode as i was advised by wcs2228, there isn’t (or I don’t know how to get to it) a way to remove DHCP.
So, the Beryl, sitting at does filter the traffic of all clients joining the main wireless router but after 10-15 I get a warning message on the Beryl’s admin page saying that there’s a IP LAN conflict and to select another subnet.
I did select a range of just 5 allowable IP on the Beryl to That range does not overlap with the range I’ve selected on the main router.

This is in Step 3 of the procedure:

On the DHCP Server tab, Check/Enable Ignore interface to turn off the DHCP server.

Will try and post the result.

I’m afraid I was not able to find the “DHCP Server tab” on my Beryl AX3000 admin page.
I triple-checked every single option on the NETWORK menu and the options are:

  • Firewall
  • Multi-WAN
  • LAN —- where router IP and IP ranges can be set
    There is a DHCP Gateway option there… that is blank
  • DNS
    -Network Mode
  • IPv6
  • Mac Address
  • Drop-in Gateway
  • IGMP Spoofing
  • Hardware acceleration
    Sorry but I’m really new to all of this.

It is in Luci. But you don’t need to change that.

Why is there no need to change that, in order to disable the DHCP server on the Beryl AX? Otherwise, there would be 2 DHCP servers on the Beryl and on the main router.

I did look in Luci but couldn’t find it.
In the meantime I reserved the range to It seems to be working so far but I’m sure there’s a more “elegant” way of achieving the goal.

Log into the LuCI UI and go to Network → Interfaces → LAN → Edit → DHCP Server:

Thanks, I was looking into the DHCP menu.