Brume Adguard All clients localhost

Dear team,

I´m trying to get Adguard to show my client IP instead of Localhost on the Dashboard.
I have read some articles where a Port forwarding should fix the issue, unfurtunatly this does not work for me in any way… Could someone provide me a easy and working way to have the Client IP addresses (and eventually DNS names) shown so I can properly track who accesses what?

Thank you

You can try this:

Port forwarding does not work for LAN-to-LAN.

I do not work for and I do not have formal association with GL.iNet

Hi,

I´m unsure how that would react with TOR and VPN. Is this safe in terms of security?

At @GLINET Team,

Can this feature be please added on new firmware releases?

Usage of ADGUARD is Brocken if all sources are “localhost” there is 0 use for loging.

1 Like

The change in the link above only disables DNS functionality in dnsmasq and enables AdGuardHome as DNS server, so any client device that uses the router IP address as the DNS server by default will be serviced by AdGuardHome, instead of by dnsmasq on the router. Client devices can still choose to use different DNS servers by specifying another IP address (e.g., 8.8.8.8, 1.1.1.1).

This is similar to users in this forum who use Pi-hole or AdGuardHome as an independent DNS server that is separate from the router, which is what I do with AdGuardHome running in Docker on a Synology NAS. I am not aware of how this impacts security if you are already running AdGuardHome on the router anyway, with client DNS requests going to dnsmasq which then makes DNS requests to AdGuardHome.

I do not work for and I do not have formal association with GL.iNet

Hi,

After performing this change it works, however I have now the issue that DNS server is not being delivered by DHCP, all clients receive no DNS server.
I tried adding the Routers option but this does not work either.

Oops. I missed a step in the procedure:

Configure DHCP server to give DNS as the router’s IP address via LuCI → Network → Interfaces → LAN → Edit → DHCP Server → Advanced Settings → DHCP-Options. Enter the following and click Save, then click Save & Apply:

6,192.168.8.1

If you have changed the router’s IP address from the default 192.168.8, then enter the new IP address preceded by “6,”

I have updated the original post. Thank you for letting me know.

I do not work for and I do not have formal association with GL.iNet

Hi,

This worked fine, one additional step would be to get the reverse DNS to work, right now I get IP´s on the dashboard, how can I force it to reverse lookup to give me hostnames?