[Bug] Flint: F/W 4.2.3-r5: Policy Based on Target Domain or Client MAC: No 'net when VPN down

I have my Flint (GL-AX1800) configured with wireguard VPN with the option “VPN Policy Base on the Target Domain or IP”.

When router loses connection with VPN Server (or VPN server is down) there is no Internet at all.
I would like the Internet to work for the domains which don’t use VPN. How can I do it?

What firmware version is your Flint using? 4.2.3-release5 is the latest on mine (GL GUI → System → Upgrade).

Check that Block Non-VPN Traffic is toggled off (GL GUI → VPN → VPN Dashboard → VPN Client → Global Options).

I’m using the latest version (4.2.3-release5) and “Block Non-VPN Traffic” is OFF.

Bear with me but does this have a similar issue when setting the policy to Client MACs? What you describe could be a symptom of a bug.

GL GUI → VPN → VPN Dashboard → Global Proxy → Modify Proxy Mode → Based on the Client Device

I’ve just changed the VPN setting to “VPN Policy Base on the Client Device”, selected one device to route all the traffic through VPN, but unfortunately the issue still persists: no Internet on devices which traffic doesn’t go through VPN (when VPN server is down).

This is smelling more like a bug. I took the liberty of retitling your thread.

Hi I just noticed you’re having problems with the VPN police settings VPN Client Policy Mode have you found a way round the problem

I haven’t found a solution. I hope future firmware update will address this problem.

Do GL.iNet technical staff aware of the problem

I’m having this issue on my Brume2 as well.

I have specific clients set to “use vpn” in the vpn multi proxy settings

If the VPN connection goes down or I disable it, every device on my network loses internet access. Not just the clients in the list like it should be.

I also already checked my global settings are all set to off.

This is definitely a bug for more than one product!

Its not a recent problem i have never got the VPN Policy Base on the Client Device to work, if you chose not to use the VPN by MAC address the device / 's not selected should act as if you have no VPN running but all other devices not selected should use the VPN or the other way round depending on the Policy, its a pain especially if you have a streaming device that don’t work with a VPN.

Tried on 4.4.5 and 4.4.6 it works normally.

Hi thanks is it best to do a fresh install or an update keeping setting OK

i’ve finally resolved the problem by performing factory reset and enabling Allow access WAN in Global Options.

1 Like