VPN Client Policy Mode

OK using A Roku with my VPN I also have Block Non-VPN Traffic enabled all works well, except one streaming service, which has blacklisted the servers I would assume, anyway disabling the VPN and disabling Block Non-VPN Traffic everything works as you would expect, BUT if I have this configuration enabling the VPN leaving Block Non-VPN Traffic disabled and in Modify Proxy Mode, I have selected Based on the Client Device, I have then selected the Roku MAC address and added it to the Do Not Use VPN list, I have also done the same for the SKY Receiver, I assumed that this would effectively do the same as disabling the VPN for both devices but barely any of the streaming services work correctly, if you add a PC as a test it works fine, any ideas would be helpful, I have tried it on two GL.iNet routers both running the latest firmware 4.2.3 (GL-AX1800 Flint & GL-AXT1800 Slate AX)

I’d expect the same, but unfortunately GL.inet has a different idea. According to various posts on this forum they claim that there won’t be any leaks without Block Non-VPN Traffic enabled. There’s some evidence to the contrary unfortunately.

Thanks for the reply, I have tried this a while ago in an earlier firmware with the same result.

I have recalled below to make or clearer for others what I’m trying to achieve,

1 To recap VPN deactivated, Block Non-VPN Traffic deactivated works as expected direct to ISP
2 VPN active, Block Non-VPN Traffic enabled works as expected all traffic via the VPN.
3 Modify Proxy Mode, Based on the Client Device chosen device not to use the VPN, Block Non-VPN Traffic disabled, causes unknown effects which streaming devices hardly work but this setting should effectively be like no VPN is running for the chose client.

I am going to try an see exactly what is happening to the device in expletive 2 which should be VPN free.

I tried 3 Modify Proxy Mode, Based on the Client Device, this time I used an iPad and indeed there are problems, I didn’t have any leaks but when I went to https://www.speedtest.net/ to do a speed test the browser timed out, so something is not working correctly.

I’m having this issue on my Brume2 as well.

I have specific clients set to “use vpn” in the vpn modify proxy settings

If the VPN connection goes down or I disable it, every device on my network loses internet access. Not just the clients in the list like it should be.

I also already checked my global settings are all set to off.

This is definitely a bug for more than one product!

When all the firmwares are released as betas why has this problem been repeatedly missed.

I think this might be a DNS settings issue

Make sure you are not using random MAC address, because when you add can change later.

I do have apple devices but they are static MAC address, the devices that should bypass the VPN are static anyway, there is a problem and has been for ages, thank you for your input anyway

I forgot to ask, I take it you have a GL.inet router, if you use a VPN try it you will find that the device chosen not to go through the VPN reacts very strangely eg some sites don’t load and if it’s a streaming device it can report no internet connection, deactivate the VPN all devices work fine, same as all devices through the VPN but make sure you have the Global Proxy set to All traffic will go through VPN.

I still think its a DNS VPN issue, when you cut everything you need to reload the page or restart browser, I will try your settings.

In your DNS you will also want to disable Override DNS setting for all clients if its enabled and set up alternate DNS in LuCi or on the device.

Also when you mark the roku not to use the VPN do you the Hard Clear the Roku Cache:
Press buttons:
Home x5
Up x1
Rewind X2
Fast-forward x2
Menu should scroll if done correctly

I can’t disagree how a PC reacts is like there is no DNS servers, i have tried both ways disable Override DNS setting for all clients, but not every time i tried it if i was honest, where in LuCi would i put an alternative DNS servers, i assumed the DNS settings would be done by AdGurard.

Why you can’t clear the cache on a Roku

The problem is that the Roku does not have a conventional cache, so there is no cache to clear. Numerous websites claim that by pressing a sequence of buttons on the Roku remote control, you can clear its cache.

Roku representatives have confirmed to Business Insider that in reality, those button presses merely reboot the Roku. To be clear, Roku devices do not have a cache.

The Business Insider piece('Can you clear the cache on a Roku?': No, but here's how to resolve playback issues | Business Insider India) doesn’t really give any information on the chip. It may not be technically fast storage buffer in the central processing unit of a computer but it is hard to reach secret information.

A regular restart does not clear the populated DNS Servers but the hard clear does ( or at least causes it to re check DNS)

Anyway so to change DNS settings in LuCi go to Network Tab then click the Edit on the network interface you want to use (I have LAN, Guest, IOT, Cameras) Once in the interface click the Advance tab DNS should be the third down.

AdGuard has a option to make custom client rules also under settings, client settings