Bug Reporting Thread For Firmware v3

Sometimes, I connect both 4G/3G and cable, but the page display unconnected status.

like this.

The screenshot you posted like the router is not connected. You can use F5 to refresh.

If I put your problem in simple words, you mean:
when working in 5G WDS mode, AR750 has to set channel in its AP in order to have its wifi broadcasting, right?

Auto channel may have problem I think. This is expected.

Yes, in simple words is that. But sometimes Auto channel connects in 5G WDS Client in one or other router…sometimes…and it always get stucked in 5.000Ghz like the picture, not another frequency in all the channels I tried.
Thx for your reply!!


Tested version: gl-ar750-3.006-1115

Today i surprise to surf around without VPN IP:

That need to be fixed.

I cannot understand your English but I think you are saying that if you try and change server manually, the real IP leaks,
This is the reason we need the Force VPN option bought back (ie. manual instead of automatic).

Also, very similar to the leak I reported here:

I didnt tell and dont mean like this.

I told abbout: The automatic “Force VPN” function from v 3.006 dont work.

I can’t reproduce the leak. As far as I can tell, once connect is clicked, then the VPN is forced.

Obviously, if you click “disconnect” then that “un-forces” the VPN until you then click “connect” again.
That is the reason I asked for a “re-connect” button to be added and the Force VPN check box to be re-instated.

Regarding the VPN section:

  1. You cannot change server in current config in Management Tab while connected to said config (this may be intentional but you can do it in the Status Tab).

  2. When you click the change server cog (Status and Management Tabs) it would be better and more logical to open with the screen scrolled so that the current server is shown.

Bugs on gl-ar750-3.009-1129.bin

2.4 GHz WLAN:


I was about to post how the Repeater Function in an environment where an SSID has many BSSIDs (i.e., hotels and other public spaces) on my AR-750S has been disappointing with the latest series of 3.X firmwares; first there was the necessity of having to manually reconnect, which was fixed, but now there’s times when I get no connectivity for long pauses and I’m assuming that’s when it’s roaming between BSSIDs and I just don’t remember 2.72 having this issue.

But if these WLAN “bugs” are actually features to help fix that, they’re welcomed (and I’m speaking purely from conjecture here from looking at the changes you’ve cited, which actually could be part of a strategy to reduce Intra-BSSID roaming times- I haven’t had a chance to try it out yet).

Packages lists Updates Problem

AR750 (WDS mode)
Cannot update *ipk packages from WebUI on my 2 AR750 routers (says Network unreachable) but can update successfully from Luci. DNS is set to xxx.8.1, the WDS AP.
Why is this happening now with this new firmware?
With gl-ar750-3.006-1115 *ipk updates were ok in both AR750 (WebUI and Luci)

AR750S (the WDS AP)
On AR750S packages Update ok (WebUI and Luci).


Update 09-12-2018
Same on last testing firmware gl-ar750-3.009-1206. Not possible to Update or install *ipk packages from WebUI. Network Unreachable pop-up. Only possible from Luci.

Update 12/01/2019
With last firmware gl-ar750-3.012-0111 the problem is solved. WebUI can Update packages lists and install from there also.

No found any issue. Could you try to reset factory settings by holding the reset button for 10 seconds? All is good for me.


AR750, gl-ar750-3.009-1129.bin.
My current situation:

It looks a little bit like the configuration on Admin menue and on Luci are different. David reported a bug which sounds like the same.

Admin menue: Missing channels on 5 GHz

At the same time the channels not missing on advanced admin menue on 5 GHz

Admin menue: Missing some speed modes on 5 GHz

I cant check do factory reset, and cant check today the real WLAN speed for limitation to 150 MBit or not. If we need, i will check later.

File Sharing configuration Erased at boot on AR750S

On every boot/power up, any file sharing setup with Luci is removed and the default sharing options are used. This is a problem especially when the share was set up with no guest access, and to require a user name and password for access. The (default) setting after reboot allows read only access to the guest account with no password required. In Luci, the previously set “Allowed users” field is also cleared.

The problem apparently is in the file /etc/hotplug.d/block/50-samba which is run at boot.

AR750, gl-ar750-3.009-1129.bin
Now i have found different on Admin menue and Luci. I describe it on follow sample:

  • Changing the 2 GHz WLAN TX power on Admin menue, dont change the value on equal Luci menue (Yes, i pressed F5 for reload).
  • A, the changing of 2GHz WLAN TX Power on Luci menue, change the value on equal Admin menue (Yes, i pressed F5 for reload).

I guess, other actual discussed AR750 (white) bugs will be releated on the same differents of Admin values and Luci values.

The GL webui is different from luci.

channel issue: GL webui has filtered DFS channel, while luci show all support channel.
speed mode: yes, there is missing some speed mode, GL webui can only select the highest speed. If it is necessary, we can add more speed to select.
wlan speed limit to 150: It works for me. Not sure why you only get 150, maybe it is limited by your laptop’s NIC.
txpower issue: It read the value from the driver, but it depends on hardware, please take the GL webui as the standard.

The handling of 2,4 GHz and 5 GHz are different on GL Web UI:

  • 2,4 GHz its possible to select some speed modes (1 MBit to 300 MBit)
  • 5 GHz only the highest are available to select (433 MBit only)

I dont know which handling are better. A booth WLAN frequencys should handled on same best way.

With same AR750 and same Laptops i get with old 2.2x GL firmware:

  • 300 MBit on 2,4 GHz
  • 300 or 433 MBit on 5 GHz

I dont find button for deactivate “WLAN coexistence” on 3.x firmware. It can be the low speed its depend on this. After deactivating “WLAN coexistence” the speed was about the double on 2.2x firmware.

Yeah, we will add more speed mode for 5GHz.

1 Like

There is a problem that the personal setting will be lost after updated to new firewares, which were released recently, from gl-mifi-3.008.bin to gl-mifi-3.009.bin . Like SSID, wifi-Key and lan ip.

At the first time after update fireware, the setting information will remain effective. But if I shut down the router then the setting information was lost. Then visit the router must from the origin Lan IP and set the language.