Bug Reporting Thread For Firmware v3

Further to earlier reported irritations regarding the VPN interface, one has to click TEN times to change the server now.
1 disconnect
2 management
3 down arrow
4 settings cog
5 down arrow again
6 select
7 OK
8 apply
9 Status
10 connect !!!

How about making this 4 clicks: Status > Provider > Server > Connect (ie. change server). In fact you could even leave out the last click if you had a VPN enabled button (ie. auto-connect to selected server).

Spot on! We need this fixed ASAP, please.

You’re right, should fix it asap.

We need a “reconnect” button for VPN. If the current server hangs, you have to disconnect then reconnect which = LEAKS. Before we could just click “apply” and it would reconnect without LEAKS.

AR300M. Firmware V3. Excellent upgrade, but do have a major problem:

If you have an independent Wireguard server, (I have many running on cheap KVM based VPS servers worldwide, so you know the problem is not related to just one server,) and you also have a web & FTP server running on that VPS server, you cannot access that web/ftp/sftp server while the AR300M Wireguard client is connected to that server. That IP is totally blocked.

i.e. You have the AR300M Wireguard client connected to an ‘xxx.xxx.x.xxx:xxxxx’ endpoint, you cannot connect to ‘yourwebsite’ based on xxx.xxx.x.xxx, (or anything under the A record of xxx.xxx.x.xxx). No SSH, no FTP/SFTP either.

Have not found a workaround as of yet, suspect it’s just a firewall setting issue. But, it is very annoying.

Note: This block does not happen while connecting to Wireguard (and sharing) via android w/VPN Hotspot or connecting directly with Linux based or forwarded clients. the block only happens with this V3 based router(s?).


yeah there is some bug with when the AP reconnects to upstream WiFi the VPN does not reconnect properly.

@glitch We have added an option to change vpn profile without data leak. You can upgrade the latest testing firmware.

My initial observations on a AR300M:

  1. SSID seems to be tied to BSSID? So if I connect at a hotel to 2nd floor AP, and walk to 1st floor for lunch, it doesn’t reconnect. I have to scan and rejoin manually.
  2. Speaking of - it seems that the captive portal doesn’t come up.
  3. When disconnected from STA, the repeater network see down for a LONG time. Used to be faster in older firmware.

After upgrading to v3, I cleared all settings to ensure it isn’t a settings related issue.

Thanks for your swift action - will test and report back.

I have different routers - AR300M, MT300A, MT300N-V2, AR750S. With all routers, which have firmware v2, I have no problems, but v3 have some bugs:

  1. No connection to my VPN server - ibVPN. This problem occurs with all routers mentioned above.
  2. No connection to the Internet using the 3G modem - Huawei E3131h-2. The 3G modem works with the AR750S, but not with the other routers.

Yeah, I’ve seen this too on 3.001 firmware on my AR-750S . Please tie the association to ESSID, in a place like a hotel there could easily be 10+ APs all on the same SSID.

It is a bug. Will fix asap.

Did you try to disable DNS rebind protection on “MORE SETTINGS”?

If you click disconnect from STA, it will also disable reconnect feature, means it won’t reconnect automatically anymore.

  1. Could you show us the log of VPN.
  2. If it works on AR750S, it should work on other routers. There is possibility of the usb port doesn’t work on other router, because other firmware doesn’t release yet.

I’ve tested and it looks like you’ve done a good job - just a click or two to change server and the leaks are fixed.
However, may I suggest a “reconnect” button for when the current servers hangs (otherwise you need to pick another server and click “change server”, then change back again!).
I noticed one refresh problem - if you are connected and change a server under of a different profile/configuration in management, then on going back to the status page the server and/or current config displays incorrectly.

On another matter

  1. can you fix it so the servers show in alphabetical order instead of the haphazard/random way they show now.
  2. there is no save settings check box under firmware upgrade.


1 Like

On v3.005, I seem to be unable to configure a new Wireguard client. I load my configs and the GUI reports success, but then reverts back to an empty client page. I’ve tried this on both an AR300M and a MiFi.

Thanks for your feedback.

It is a bug, had fixed.

Yup, will add this feature.

Would it be caused by browser cache?

Thanks for your attention on all matters.
Regarding the keep settings - obviously my error!

AR750 white, v3.005-1024 or 1026

Button “Share via LAN” cant be dissabled on
(no USB Stick or micro SD connected)

Thanks, please let us know when the bug is fixed.

DNS rebind protection was already disabled. I also tried toggle on/off just to make sure it was properly off.

I meant disconnected by walking away from the AP. I’m at hotel, i go outside to cafe to meet a friend and come back… it doesn’t connect/the STA is down for extended time. However, the 3.005

It seems like the WISP mode isn’t working on my AR300M with v3.005.