Bug Reporting Thread For Firmware v3


#41

If you don’t care data leak, seems you don’t need OpenVPN. For most users, they worry about data leak.


#42

yeah! I agree with it.


#43

If you want to disable it, you can click disconnect button, it won’t reconnect.


#44

The new VPN interface does not allow to change or (even just restart) VPN servers while the leak protection is enabled. You have to disable VPN.

If you have split tunnel, you do away disabling the VPN to restart/enable another VPN etc, but another use cases


#45

right, but there is no - restart button - which would restart vpn while keeping the ‘kill switch’ active to prevent leaks


#46

I do care about data leaks! That’s why we need both the enable and kill switch buttons back!
This new interface is dangerous, as you have to disconnect to change servers (same provider) and during this disconnect/connect cycle you are leaking!


#47

Further to earlier reported irritations regarding the VPN interface, one has to click TEN times to change the server now.
1 disconnect
2 management
3 down arrow
4 settings cog
5 down arrow again
6 select
7 OK
8 apply
9 Status
10 connect !!!

How about making this 4 clicks: Status > Provider > Server > Connect (ie. change server). In fact you could even leave out the last click if you had a VPN enabled button (ie. auto-connect to selected server).


#48

Spot on! We need this fixed ASAP, please.


#49

You’re right, should fix it asap.


#50

We need a “reconnect” button for VPN. If the current server hangs, you have to disconnect then reconnect which = LEAKS. Before we could just click “apply” and it would reconnect without LEAKS.


#51

AR300M. Firmware V3. Excellent upgrade, but do have a major problem:

If you have an independent Wireguard server, (I have many running on cheap KVM based VPS servers worldwide, so you know the problem is not related to just one server,) and you also have a web & FTP server running on that VPS server, you cannot access that web/ftp/sftp server while the AR300M Wireguard client is connected to that server. That IP is totally blocked.

i.e. You have the AR300M Wireguard client connected to an ‘xxx.xxx.x.xxx:xxxxx’ endpoint, you cannot connect to ‘yourwebsite’ based on xxx.xxx.x.xxx, (or anything under the A record of xxx.xxx.x.xxx). No SSH, no FTP/SFTP either.

Have not found a workaround as of yet, suspect it’s just a firewall setting issue. But, it is very annoying.

Note: This block does not happen while connecting to Wireguard (and sharing) via android w/VPN Hotspot or connecting directly with Linux based or forwarded clients. the block only happens with this V3 based router(s?).

Ideas?


#52

yeah there is some bug with when the AP reconnects to upstream WiFi the VPN does not reconnect properly.