Bug Reporting Thread For Firmware v3


#61

On v3.005, I seem to be unable to configure a new Wireguard client. I load my configs and the GUI reports success, but then reverts back to an empty client page. I’ve tried this on both an AR300M and a MiFi.


#62

Thanks for your feedback.

It is a bug, had fixed.

Yup, will add this feature.

Would it be caused by browser cache?


#63

Thanks for your attention on all matters.
Regarding the keep settings - obviously my error!


#64

AR750 white, v3.005-1024 or 1026

Button “Share via LAN” cant be dissabled on http://192.168.8.2/index#/share
(no USB Stick or micro SD connected)


#65

Thanks, please let us know when the bug is fixed.

DNS rebind protection was already disabled. I also tried toggle on/off just to make sure it was properly off.

I meant disconnected by walking away from the AP. I’m at hotel, i go outside to cafe to meet a friend and come back… it doesn’t connect/the STA is down for extended time. However, the 3.005


#66

It seems like the WISP mode isn’t working on my AR300M with v3.005.


#67

Yup, “Share via LAN” is always enabled. We can’t disable it.


#68

It works for me perfectly. Do you upgrade it without keep settings? Please check the log, you can find it on luci -> Status -> System Log.


#69

Thanks for replying.

I have not kept the settings.I actually did a revert from the gli ui and the luci ui.

it works OK on known hotspots with password (my cellphone hotspot, or my home’s guest accont). BUT on public hotspots where a captive portal is involved, traffic doesn’t seem to flow.

I can get it to connect, but no traffic. At one public hotspot, it did connect to regular internet, but as soon as I added an .ovpn profile, all traffic stopped.

What’s weird is, even if i revert back to 2.264, the behavior is same. It used to be fine on the older firmware. I will try to get logs when i’m out again.

Thanks!


#70
  • SMS icon only appears once when refreshing the entire page. Navigating within the UI will cause the new SMS icon on modem interface to disappear. Although the API did returns the number of new SMSs.

  • In repeater mode, different base stations will be treated as different Wi-Fi networks. But in “saved networks” only shows the SSID, no BSSID or channel info are presented. It’s kinda confusing. (More like a feature request) Wish the repeater simply ignores the difference of the BSSID and channel settings and try to connect to the same SSID every time.


#71

Thanks for your feedback.

You’re right, it should show BSSID as well. Actually, there is an issue if we ignore BSSID to try to connect the same SSID every time, as different SSID might have a different password.


#72

But identifying WLAN networks using SSID instead of SSID + BSSID + Channel (I guess this is how GLv3 firmware and OpenWRT built-in wireless client mode does) is pretty much the industry standard, I guess? Like any iPhone, Mac, Windows and Android devices. They all consider networks with the same SSID will have the same password. And this is how things should be and will be in most of the cases. Since this allows wireless roaming to be possible.

So like my original bug report (or more like feature request, sorry for not putting it in the v3 feature request thread) states: It would be nice if the wireless repeater actually remembers SSID only and tries to connect to the known networks ignoring the channel and BSSID differences. (or offers a choice to users) Otherwise every single time you go to a new places, like Starbucks, you have to scan and add a new network again. Even though there are already like 5 “Starbucks” in your “saved network” list.


#73

Agree it’s possible - but most like Hotel WiFi - mass transit free wifi, ISP wifi, all have same or no password. So when moving within their covered locations, it’s no ideal to have to reconnect to new BSSID.

What about having a toggle on wifi page? Something like Allow AP roaming? or AP Agnostic? This way for public AP where it’s known shared you can set to allow and ignore BSSID.

If friend A and friend B both have home AP set as “NETGEAR” - toggle OFF so that you can specify two.

BTW - my issue with WISP still happens - so far the only way I can connect is to connect phone, then clone mac. old firmware worked without needing that (at least on Android)


#74

Exactly, just like what I said in this following post:

It would be nice if there is a toggle that allows AP roaming.

As for WISP (captive portal pages) issue, try toggling “DNS Rebinding Attack Protection” off under “MORE SETTINGS -> Custom DNS Server”. Also toggle off any other DNS related settings that might affect the redirection of the captive portal pages. Which includes VPN, proxies, etc…


#75

Which firmware do you use? We have fixed this issue on v3.005.


#76

Sorry for the misleading expressions. I mean:

  • But identifying WLAN networks using SSID instead of “SSID + BSSID + Channel” is pretty much the industry standard.
  • Using “SSID + BSSID + Channel” is how GLv3 firmware and OpenWRT built-in wireless client mode identifies networks.

I’m running v3.005 on GL-MIFI. Confirms the wireless repeater will treat AP with same SSID but different BSSID as separate networks. Therefore AP roaming is not possible.


#77

Yes, I agree. We had fixed this issue. Only using SSID now.

I apologize for any inconvenience caused, MIFI didn’t update the testing firmware yet.


#78

Neither is AR-750S, please update.

I’m in a hotel now and can’t use my Slate because of the SSID roaming issue

FW 3.005.


#79

Here is an emergency build for you @kennethrc

https://www.dropbox.com/s/fzah48dbqlgubn8/gl-ar750s-3.005-1031.zip?dl=0


#80

Dude, thanks … so far, so good!