[bug] v2.19 can not detect USB disk

I’m using AR-150.

2.12, 2.13, 2.18 is OK.

Only 2.19 has problem.

I just tried mine AR150 with V2.19 and it works fine.

Mine is NTFS formatted ELECOM 4G USB memory.

I think that it’s a kind of S/W problem.

Another things OK with V2.19

  • Sandisk 8G(FAT32) / Sandisk 16G(NTFS) / Imation 4G(FAT32) …

But only ELECOM4G is’nt detected in V2.19

can you format it as another format?

Sure. I tried fat32.

I have a GL-MT300A, and am having the same problem where I can’t get USB hard drives to mount. I have tried two drives, WD and seagate formatted as NTFS, neither will mount. I ordered a “Y” cable because I thought it might be power related, but the drives still don’t mount. Here is a snippet of the kernel log when I plug it one of the drives:

[ 346.480000] usb 1-1: new high-speed USB device number 8 using ehci-platform

[ 346.630000] usb 1-1: no of_node; not parsing pinctrl DT

[ 346.630000] usb-storage 1-1:1.0: no of_node; not parsing pinctrl DT

[ 346.640000] usb-storage 1-1:1.0: USB Mass Storage device detected

[ 346.660000] scsi host4: usb-storage 1-1:1.0

[ 347.660000] scsi 4:0:0:0: Direct-Access Seagate BUP Slim SL 0302 PQ: 0 ANSI: 6

[ 347.660000] sd 4:0:0:0: no of_node; not parsing pinctrl DT

[ 347.680000] sd 4:0:0:0: [sda] Spinning up disk…

[ 348.690000] …ready

[ 349.700000] sd 4:0:0:0: [sda] 3907029167 512-byte logical blocks: (2.00 TB/1.81 TiB)

[ 349.980000] sd 4:0:0:0: [sda] Write Protect is off

[ 349.980000] sd 4:0:0:0: [sda] Mode Sense: 4f 00 00 00

[ 349.990000] sd 4:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn’t support DPO or FUA

[ 350.080000] sda: sda1 sda2

[ 350.090000] sd 4:0:0:0: [sda] Attached SCSI disk



Sees you hard drive is detected. Pls try to see if there is device like /dev/sda1 /dev/sda2

Try a manual mount like: mount -t ntfs /dev/sda1 /mnt/sda1

If you can mount manually, which means the scripts has bugs.


Yes, I was able to mount it at /mnt/sda2 manually using your command above. I did have to mkdir /mnt/sda2 first. Is there anything I can do to help you find the bug?

the hotplug script is here: /etc/hotplug.d/block/50-mount

You can check the content and modify it to see if you can let the firmware mount automatically.

I’m not a coder, but looking at the script I think the issue may be that it wants to mount device with names like mmcblk0, and doesn’t’ look for sda1, sdb1, etc. However, I don’t have the skills to modify it and check. I also assumed you meant /etc/hotplug.d/block/10-mount because there is no 50-mount, just 50-samba.

Edit: Nope I was wrong, it mounts my ntfs flash drive which is /dev/sda1 to /mnt/64 no problem. No idea why it doesn’t want to mount hard drives.

One help please .In my glinet 1300M wifi is not emitting .so please give some solution.

Hi, similar problem here.
Just powered on my first GL-AR300M-EXT, so please excuse any publically expressed noob-ness.

I see the ntfs formatted drive gets recognised (/dev/sda), it even gets mounted as /mnt/Basic\ data\ partition, /mnt/EFI and /mnt/System\ partition but does not show up in the web interface.

What needs to be done to share the drive through the AR300M?

Can you change the label to something not including space?
For example “Basic\ data\ partition” to just “basic”

Yes I can sir. I stopped the samba service and renamed the mount point to ‘Data’.
Drive still not visible in UI and after reboot happily back to /mnt/Basic\ data\ partition.

I even deleted all partitions on the drive and created a single large partition, NTFS formatted, named ‘Data’.
Still it gets mounted as Basic Data Partition.

Also, creating a symbolic link ‘Data’ to this spaced mount point does not get this to work.

Perhaps the output of df -h provides a clue on what to do next?

root@GL-AR300M:~# df -h
Filesystem                Size      Used Available Use% Mounted on
/dev/root                 8.3M      8.3M         0 100% /rom
tmpfs                    61.0M    456.0K     60.5M   1% /tmp
/dev/ubi0_1             100.6M     72.0K     95.8M   0% /overlay
overlayfs:/overlay      100.6M     72.0K     95.8M   0% /
tmpfs                   512.0K         0    512.0K   0% /dev
df: /mnt/Basic\040data\040partition: No such file or directory

I eventually deleted all mount point and am looking for another way of sharing my files.
Perhaps this will be tackled in a future version. Feel free to contact me to get this resolved.

you need to change the volume label, not rename the mount point.

Plug it in your pc and change the volume label. Then try in the mini router.