Can’t tether w/ iPhone, GL-AR750S

Hi, I’ve been trying to get the tethering to work from my iPhone XS, but I keep getting the connection error.
I tried doing the steps listed on this thread: https://forum.gl-inet.com/t/can-t-tethering-with-iphone/537. However, I still can’t get it to work. Is there anything else I can try? Thanks!

Thank you! I tried this and it worked right away! I wonder why disabling bluetooth helped :thinking:, thanks again!

I think it can be pretty random - I don’t remember dealing with this quite as much on the GL-AR750S as I did with the mango.

Hey @alzhao … maybe these trouble shooting steps can be put into the official documentation now?

1 Like

Thanks for this useful information. Yes we will put in troubleshooting.

I’m still getting issues connecting now, even after the method that @chromebook suggested. I’ve retried connecting several times, and still getting the error. Is there anything else I can do to make connecting more reliable?

The tethering is the most reliable thing for me with these routers. I plug my phone in and BAM! Internet.

Now, the only difficulty I have sometimes is the initial pairing - never had an issue beyond that.

Once initial pairing complete, I leave the ‘personal hotspot’ toggle activated all times in the iphone settings.

Bear in mind this does not leave tethering on all the time… only means that your phone is not blocking tethering.

You can long press the wifi and bluetooth buttons in control center to access a quick button to temporarily activate wifi and bluetooth tethering.

You do not need to interact to make usb tethering just work beyond plugging in the phone in my experience.

If you switch the toggle to ‘off’ then I think you have to put your password in to ‘trust this device’ each time before connecting.

If you are using wifi tethering via the button in control center, the name of your network will only appear for a few minutes and will eventually become hidden. If you activate wifi tethering from the toggle in ‘personal hotspot’ settings, the wireless network will stay visible indefinitely (or until you leave that screen).

Hope that helps

Whenever I connect my phone to the router, it requires me to connect from 192.168.8.1 every time. There weren’t any problems with connecting the day that you suggested to disable bluetooth, but now it seems to refuse to connect for some reason.

I just kept the phone on usb tethering, i don’t enable the wifi/bluetooth in the personal hotspot. Sometimes “trust this device” appears when i connect the phone, and sometimes it doesn’t.

Thank you for the help and the response nonetheless, I appreciate it :slight_smile:

Hey one other thing!

Once you have trusted and you leave that toggle enabled, you won’t have to actually select trust again… you can tap whatever and it will still work.

I think flipping the toggle resets the requirement to trust a device, but you get prompted each time. Kind of how you get prompted to share photos everytime you connect to a PC.

Maybe your configuration is weird.

Perhaps try once again from scratch by resetting the router and following the correct method?

Okay, so I did the following steps:

  1. Revert firmware
  2. Connected to the Wi-Fi again on the computer and did the router setup
  3. Plugged in phone, the phone asked to enter password to trust the device, and I did that
  4. Toggled the personal hotspot while having bluetooth and wifi disabled
  5. Pressed connect on the router homepage
  6. Since the above didn’t work, retried toggling personal hotspot as shown in the troubleshooting docs

Still getting the error :frowning: , I’m really not sure what to do now.

And wifi and bluetooth is truly disabled… not just ‘disconnected’ and it asks you if you want usb-only?

Well that sucks. It seems that you have tried everything. It is possible that there is some bug with iphone tethering packages with newer models.

You could look and see by searching for openwrt related iphone tethering issues. If it’s just the case of some outdated packages, I’m sure that the gl-inet staff will happily update them for you.

Yes, if it asks to connect, it shows usb-only.
Fortunately I also have an android phone to use, so I just swapped the SIM and it worked without hassle. However, when I have more time I will try to figure it out. I did some searching around thanks to your guidance, and I think you are correct in that the packages could simply just be outdated and needs some updating.
Thanks again for all your responses, you’re awesome :slight_smile:

I had my phone upgraded to ios14. I can still set up tethering and router can get IP. But I cannot access Internet. Seems ios14 breaks something.

Hello,
I have the same issue but when using wireless sharing, I have unlimited data and want to share it with the router which would handle all the networking staff (all my other devices would connect to it instead of my iPhone), unfortunately it’s not working reliably at all, the router keeps disconnecting from the iPhone, it just unusable.
I’ve an android phone that I tried and it works just fine, it driving me nuts, any help would be appreciated.
Thanks

Yep, same here. Upgraded to iOS 14 and now tethering no longer works.

I was able to get it to work using the Wi-Fi repeater mode and connecting to my phone’s hotspot, but tethering still appears to be broken for newer iOS devices.