Cannot get VPN client to work on Mudiv2

Hi there,

Bought a new Mudiv2 without any research at all as my Christmas Gift. Just opened the box but can’t get the Mudi to connect to NordVPN (although it’s as simple as a built-in option, and I certainly entered my Nord login details correctly).

This error message keeps looping “The client is starting, please wait…”

Any idea please? Thank you

1 Like

Where are u from? If a normal country i think wiregaurd is better than openvpn. Not sure if ur router supports it. But dealing with openvpn is not as easy as u think

Good advice thanks - I just copied the service credential + password across, then tried to enable connection to one of the server, but still no luck. The same “The client is starting, please wait…” prompt.

1 Like

Thanks but I’ll stick with OpenVPN for now. I own 2 Opal routers and setting OpenVPN up on Opal was a breeze. It’s strange that the same steps aren’t working on Mudi v2 now

1 Like

Could you please export the full log and upload it here?
Is your Mudi connected differently to the internet?

1 Like

I had same issue too with openvpn on my flint 2. Its stuck in starting client… even on a server which i wad sure it should connect! I only remember once out of no where it turned green ( connected) and that was when my vpn was on on laptop! That was weird

Thanks so much, is the below sufficient?
(Mudi is connected via WIFI Repeater to my home Internet)

Sun Feb 4 14:50:18 2024 : VERIFY KU OK
Sun Feb 4 14:50:18 2024 : Validating certificate extended key usage
Sun Feb 4 14:50:18 2024 : ++ Certificate has EKU (str) TLS Web Server Authentication, expects TLS Web Server Authentication
Sun Feb 4 14:50:18 2024 : VERIFY EKU OK
Sun Feb 4 14:50:18 2024 : VERIFY X509NAME OK:
Sun Feb 4 14:50:18 2024 : VERIFY OK: depth=0,
Sun Feb 4 14:50:18 2024 : Control Channel: TLSv1.3, cipher TLSv1.3 TLS_AES_256_GCM_SHA384, peer certificate: 4096 bit RSA, signature: RSA-SHA512
Sun Feb 4 14:50:18 2024 : [] Peer Connection Initiated with [AF_INET]
Sun Feb 4 14:50:19 2024 : SENT CONTROL []: ‘PUSH_REQUEST’ (status=1)
Sun Feb 4 14:50:24 2024 : SENT CONTROL []: ‘PUSH_REQUEST’ (status=1)
Sun Feb 4 14:50:24 2024 : AUTH: Received control message: AUTH_FAILED
Sun Feb 4 14:50:24 2024 : SIGTERM[soft,auth-failure] received, process exiting
Sun Feb 4 14:50:25 2024 : cat: can’t open ‘/tmp/run/ovpn_resolved_ip’: No such file or directoryn_resolved_ip’: No such file or directory

I also see an “IP Masquerade” function in the Mudi Admin Page and it’s turned on. Does that affect the connectivity and should I turn it on or off? Thanks again

Your user / password is wrong.

Let me guess: NordVPN?
In that case you need to get the right credentials from the dashboard.

1 Like

Do you recommend PIA ( private internet access) ? i can connect with it on my home wifi internet via wireguard. when @bring.fringe18 gets back i wanna try it on my flint 2
if it connects on my ubuntu laptop i think it must connect on FLINT 2 too. since both are linux.
do u agree @admon ?

PIA is supported by the stock GL firmware. Let’s move this discussion back to the main thread.

1 Like

Pls fix the nord credentials

Just to close the loop on this one - the Mudi VPN finally started working for the first time after I reset the firmware to factory settings (not sure why as I only changed the passwords on the device)

Anyway, just happy that it’s working, have a great weekend all!