Can't get to captive portal (hotel) using repeater mode (Beryl/MT1300)


I could really use some help/tech support. I purchased the Beryl for our travel router and love it. Had it setup on our home network perfectly. I also reached out prior to travel/purchasing to ask if it would be compatible with a hotel’s captive portal system and was told that it will work with it.

However, we’re staying at a hotel with captive portal and I cannot seem to get Beryl to pass along the captive portal page. I’ve tried using my phone and iPad Pro. In addition, I’ve searched online and I did read the FAQs and I disabled the DNS rebind protection under the Custom DNS Server option. This didn’t help. I did also follow the instruction to disconnect from the WiFi and reconnect and still couldn’t get it to pass me through to the captive portal. I also tried to go to another webpage hoping that would put me through to the portal but it didn’t work either. It would make everything so much better if I could get this working. Otherwise, I don’t really have any reason to have it.

Lastly, just to add, I also tried to use the GL.iNet app to see it if would better but it didn’t work either. Really frustrating.

Any help would be amazing. Thanks so much!

Just to add, the captive portal works perfectly when connecting directly to the hotel WiFi from my smartphone or iPad. No issues there. Support had me try using WDS but that didn’t work at all. It bridged the connection but there was still no internet.

As I look, it appears that Beryl connects to the internet briefly (I get a success notification) but then when the page refreshes to the main landing page, it shows that there is no connection. It’s like because I never get the captive portal page, it never really connects.

Lastly, I don’t know if this matters, but it appears that my firmware version is 3.200. Are there any known firmware issues that the new version may fix? I’m so frustrated. This was supposed to make things easier not worse. And the thing that’s difficult is that I really like the router. I want this to work.

Try going to a site that you haven’t been to, especially an http site that isn’t in your browser cache.

I find usually works to trigger the captive portal. This always seems to happen to me on a delta flight.

Which hotel are you in? It seems that in some hotels they are trying to block router.

After you connect your phone to the hotel and get authorised, can you clone your mac address to the router to see if it works?

I’m so frustrated by all this. Support had been worse than useless and hasn’t even tried to help. These forums have been the only glimmer of light I’ve had.

I’m in a Comfort Suites. The word thing is I can seem to get Beryl to really connect at all. It shows success for a serving then shows I’m not connected when it reverts to the main page. I’ve tried to do the MAC clone but I can’t get that to work either and I’m not sure if I’m even doing it right. I connect to hotel, go through captive portal, switch to beryl direct WiFi so I can control it, I then go to more:Mac clone and choose my phone’s MAC address. It successfully uses it but still can’t connect to the internet when in try to connect to the hotel as a repeater.

I’m super frustrated to learn that I can use the luci interface on this unit either. I don’t understand that choice. This has been a massive exercise in frustration and hasn’t made this trip easier but actually more difficult. I’ve been super disappointed in how support hasn’t helped any either.

Sorry for the vent. I’m so, so grateful for your thoughts and ideas from the people in this community. Honestly, it’s the one glimmer of hope I’ve had.

Found your post looking for help with a captive portal at a Courtyard. Couldn’t connect to the conference wlan with my MT1300 but it worked for the hotel guest network. I disabled the Cloudflare DNS over TLS and I finally got the MT1300 to push the captive portal through to my computer…

I just followed the “repeater” instructions as normal, and was good to go. Hope that helps

I think I figured it out. When you get a blank captive portal page it means the redirect didn’t resolve right. Look at the internet page on your admin panel. If Marriott courtyard Olathe dns server is probably something like or close to it. Go into your network settings and manually make your dns server that address instead of the default Then open a web browser and go to the up address of that dns server and it should bring up a working captive portal page. Once you go thru it it should connect.

1 Like

Do you mean you can connect to Marriott hotel wifi as repeater?

I got report that the router cannot connect at all, i.e. there is no way to get IP address.

Hello Raening and All,

I have had this problem twice and the solution that worked which I stumbled on by accident is below ( and as suggested also by Lousy ).

But I think we now need to know if there are any security implications of making this change - this is what concerns me and I’m sure everyone who is using this to protect themselves on public wifi. I do not have a complete enough understanding of what’s going on to judge this, nor do I understand why this DNS setting on my device should effect whether the router connects or not … I’m hoping someone will explain.

Sorry that this is for Apple. For Windows, there is something very similar. Start by looking for your network settings on the device that you are using.

So, you have tried “Mac cloning” and the public wifi shows up in Beryl settings but doesn’t give you access to the internet. On Apple ( mine is OS 10.14.6 ),
First use your browser to log into Beryl and, looking at the details of the hotel (or other public) wifi, note down the address of “DNS server”. In my case and just to show you the format, it is

Click on the wifi strength symbol top right of your screen
Click “Open Network Preferences”
Click “Advanced” button
Click “DNS” tab
My “DNS servers” on this screen reads which is Beryl’s address.
Click the + button bottom left of the window.
This will give you a which you can change
Fill in the address of the hotel DNS ( from the first step, mine was )
Click OK
Click Apply.

That’s it!

I hope that works for you and others and that someone can answer the technical questions about it.
I tested with after doing this and all seemed well security wise but I would definitely like knowledgable confirmation.

1 Like

I marked this thread done. But I think it need further investigation. The solution seems should be related to dns rebind protection.

1 Like

1 Like

Do you have some explanation? I can guess, but it is better to have text description so it is easy to undertand.

Well, when I go to a new place where I have to use the GL -AR300M to access the Captive Portal, I get a new link in my Hostnames. I thought that sharing those might encourage others to share theirs. If I had an extensive list in my Hostnames it might be beneficial. My wife and I are in an RV and travel a lot.

So after setting these hostnames, the portal can pop up correctly, even with DNS rebind protection turned on, right?

This I don’t really know as I always turn off the DNS rebind protection until after I have set the captive portal correctly… then I turn the DNS rebind protection back on.

I don’t know why this works, I only know it works everytime.
Reset the firmware. Try it. My hotel renews the signon every month. Every month the router cannot connect. I reset the firmware and it works.

I’ve encountered the same issue with my Beryl and Slate AX. I’ve now succeeded every time doing this:

  • Log into Slate AX
  • Disable DNS Rebinding Attack Protection
  • Log into hotel wifi
  • Use “Network Scanner” (free Android app) to find hostname and IP of gateway
  • Connect to Slate AX Web interface (app will NOT work)
  • Add gateway hostname and IP to “DHCP / DNS”, “Hostnames” tab in Luci
  • Start Repeater
  • Open new Web page and captive portal should appear

I’ve also cloned my phones MAC address with the router. I don’t know if this is necessary
Note that setting the repeater in the android app wont work as the landing page will not appear. Sign in to router via WAN IP using browser.
Hope this helps. It’s a faff but it works.


I am not sure why you have to add IP and hostname manually.

It is a local dns so disabling DNS rebinding attach protection should be enough. Is there a reason it is not.

That I can’t answer. All I can say is this has been the only way to force the landing page to launch. It’s also odd that I have to use the GUI rather than the app to set up a new Repeater connection… I’m currently in a hotel so will factory reset my Beryl later and try again from scratch

In the screenshot above is ‘index.htm’ and ‘loginok.htm’ as hostnames. These are a filenames, not hostnames.
I wonder if the (correct) hostname is even relevant for the process.

I try to follow the process:

  1. connect phoen/tablet/laptop ti the GL.iNet router
  2. connect gl.inet Router to the hotel (W)LAN
  3. open any website
    [the magic begins]
  4. I want to go to
  5. The hotel (W)LAN redirect this to the captive portal
  6. I need to to that is written on the paper (enter a code, accept NDA, whatever)
  7. After success the Hotel (W)LAN is redirecting me to the requested site (

I don’t know why a nslookup (from the example screenshot above, sure test with the domain/hostname from your “Network Scanner”) should give another answer before and after the captive portal login. But I would check this after ‘Log into hotel wifi’ and after ‘Open new Web page and captive portal should appear’.

Even HTTPS should not be a problem, because the DNS setting are far away from the certificate exchange.