Can't get to captive portal (hotel) using repeater mode (Beryl/MT1300)

Isn’t the hostname a long way around to just entering the default gateway in the webbrowser? I mean, if you discover that your hotel’s gateway is, shouldn’t entering that land you the captive portal instead of

Also, clearing the browser cache might help. If you’ve gone there before, may go out as an https request and get blocked unless it is in the local file.

Well - I’ve managed to leave my Beryl on my desk at home so I won’t be testing with that. I’ve just backed up my Slate AX but can’t get it to reset to factory or even reset the login. A 4 second press does nothing and a 30 second press just leaves it so that it can’t be accessed - no SSID broadcast. The last thing to try is a Luci revert to firmware but I’m on vacation and don’t want to be getting involved in that stuff. What is the procedure for factory reset. Hold Reset for 10+ seconds whilst powered on or gold Reset, power on then continue to hold for 10+ seconds?

Being a sad man I do take a laptop away with me when on holiday :(. Every process works flawlessly using a laptop instead of my Android phone. I was struggling to get my Wireguard config file to work using my phone. Copy & Paste didn’t work, neither did browsing to config file. Dragging config file in Windows worked perfectly. So Windows (Chrome & Edge) just don’t have a problem. Landing page - seamless. Just works. To get this far I did a Firmware reset via a browser login on my phone and used my Windows laptop to configure. All good. Hope this helps!

You did the reset wrong.

While the router on, hold the reset button for 10 seconds until the LED flash 4 times per second, release your finger.

Do not hold the reset while powering on, it is entering the uboot failsafe mode.

1 Like

Many thanks Alzhao,
I’ve searched everywhere for the reset instructions for the Slate AX…
It does look like the process doesn’t work as designed when I use my phone. Without playing about in Luci the landing page never opens. I’m on Android 10 and I’ve tried Chrome & Samsung Internet. I did more tests and using a Win10 and Win11 laptop using Chrome, Edge and Firefox there are no issues. I also tried my TP-Link AC750 and an old RAVPower FileHub and they were fine. I’m now back home so we’ll see what fun we have next time.
The Slate AX really is a brilliant bit of kit. Super fast over Wireguard and good with NordVPN

Bump, for hotel issues I think some hotels are simply sending their captive portal auth page out with TTL = 1, so from my other post:

The particular provider for this hotel used a simple trick to try and prevent travel routers, their captive portal auth page is sent with a TTL of 1.

Added this to the custom firewall option:
iptables -t mangle -I POSTROUTING 1 -j TTL --ttl-set 65
iptables -t mangle -I PREROUTING 1 -j TTL --ttl-set 65

First line I don’t think is necessary but is taken from another blog, and the second line I had to google for as I didn’t really need the outgoing to have a higher TTL but the incoming.


I tried both FrAgGIE and Ades’s solutions and neither worked for me.

Does anyone know of some other way to resolve the issue?

The higher TTL out mean they cannot be nasty and block all traffic that already got its TTL decreased because of a travel router.

I believe you can also do:
iptables -t mangle -I POSTROUTING 1 -j TTL --ttl-inc 1
iptables -t mangle -I PREROUTING 1 -j TTL --ttl-inc 1

So you just increase TTL by 1 (then decrease it by 1, because it is routed by the router), so it stay the same but the router simply does not count in there.

One thing that I must recommend is to go to the Advanced Settings and run the LuCi to access the backup. Make a backup of what you have that actually works. I do this almost every month and everywhere I go. Then - When I get stuck somewhere that there is a Captive Portal, I simply reset the router (Mine is a GL-AR300M) and start fresh. First, you have to reset the password, then set the time. Sometimes I have to update the Plug-ins a couple of times. Then I make sure that I clear out the memory of my browser. That works “Most of the Time”. Then, after getting past the Captive Portal, I make sure that I set my VPN and such. *** Make a backup of your setting for that location. I have backups for several places (restaurants, KOA’s, Motels, schools, etc.). It works about 95% of the time.