Can't successfully connect to Marriott Hotels as repeater

@kennethrc Sorry, but can you give a newbie-friendly instructions of how you did this?

How do you discover the captive portal address?

How do you discover the original WAN side DNS servers?

How do you map the IP address? How to do this ephemerally?

Thank you! I am at a Mariott Residence Inn right now and encountered this same issue. Adding the hostname pointing to the default gateway in the advanced settings allowed me to get this all working. Never had an issue at Marriott hotels until this one. But this is a newer hotel, so maybe they have updated technology.

For those asking about how to receive the captive portal - here is how I did it. First connected to the Mariott wifi with my phone and was able to get registered. Next, I setup my router to connect to the hotel wifi and did a mac clone to my phones MAC address. Then when I connected the phone to the router, I got a wifi notification message on my phone that I needed to log in to the network. When I clicked on that notification, it took me to a chrome error page saying it couldn’t resolve the address. The error message contained the capitve portal address of: mspwb2.cust.blueprintrf.com, so I plugged that in to the hostnames and it worked.

I struggled with this as well. It works fine with my Hootoo Router (that thing connects to anything!).

Anyway the GL.iNet admin panel showed the DNS server for the Marriott Network (TOWNEPLACE_GUEST in this instance). I put that DNS into my Mac’s DNS setttings and it was able to load the blueprintrf.com screen. That part wasn’t working before I tweaked the DNS.

Now the Wifi works.

Hope that helps some other folks.

The instructions here are very unclear about what needs to be done. Burt whatever I have deciphered from here and tried simply doesn’t work. Tried using both cable a wireless repeater.

This is exactly why I bought the AR300. As it doesn’t work I will need to return it.

Sods law. I have, after a nights sleep and several more hours, managed to do this. The instructions from the above, after picking through what people actually mean (when you’re giving instructions on how to do something, please be very clear!) are what you need to do.

Note you need to do these steps all from the same laptop and BEFORE you connect to the Marriot’s WiFi. This is really important (happy to be proven wrong on having to do it before you connect - when I tried to do it after I connected it just didn’t work). Note I also had to factory reset my GL.iNet - I highly doubt you will but I had played around with it and wanted to start from a clean slate. But just bear that in mind.

I’d also suggest you reboot your GL.iNet and disconnect all other WiFi devices (both of these shouldn’t be necessary but just in case lets do that). Finally I also have no Custom DNS Server settings configured (in the menu go to ‘More Settings’ -> ‘Custom DNS Server’ and make sure all of the settings are turned off). Again I don’t know if this is required.

  1. From your laptop, connect to the GL.iNet admin panel.

  2. Go to ‘More Settings’ -> ‘MAC Clone’ in the menu.

  3. From the drop down list in the MAC Clone screen, select the MAC address that is shown as (clone). Click ‘Apply’.

  4. In the menu, click ‘Internet’. Then, in the box with ‘Repeater’, click ‘Scan’.

  5. When the scan is complete select the SSID you want to connect to (for example, mine was TOWNEPLACE_GUEST) from the drop down menu and click ‘Join’.

  6. In the menu, click ‘Internet’ again and refresh the page until you see the TOWNEPLACE_GUEST (or whatever yours is called) connected and with an IP address. Make a note of the IP address that is listed for ‘Gateway’ as we will need it later.

  7. I am using Firefox so when this happened I got a ‘You must login to your network connection’ (or something similar pop-up). Click that button and you will see the WiFi sign in page pop-up. It will fail to load, but that’s fine. If you don’t get that pop-up then people have said above you can try to browse to cnn.com or neverssl.com - the point is you need to get the WiFi signin page to appear, and fail to load.

  8. Once you get the WiFi page failing to load you will see, in the address bar of that page, something similar to https://mcita.cust.blueprintrf.com:8001 - the bit we need for this is after the // and before the : - so mcita.cust.blueprintrf.com in our case. Make a note of it.

  9. Go back to the GL.iNet admin console and on the menu click ‘More Settings’ -> ‘Advanced’. Login when prompted (username is root and the password is the same one you use to login to the GL.iNet admin console).

  10. When logged in, from the top menu click ‘Network’ -> ‘Hostnames’. Click the Add button. In the first box, under ‘Hostname’ enter the name we made a note of in step 8 above (ours was mcita.cust.blueprintrf.com). In the second box under IP address select the IP address that we noted for the Gateway in step 6 above (it will likely end in .1). Click ‘Save & Apply’. Wait for around 30 seconds. This might not be necessary but lets just do it to make sure it applies properly.

  11. Go back to the WiFi login page that failed at step 7 and refresh it. Two things will happen here - the page will either load and you can then login to the WiFi, or it will fail to load again in which case wait 30 seconds and try again. If it fails to load on the second or third attempt my suggestion would be to reboot the GL.iNet and then go back through these steps again. If this still doesn’t work then there are lots of things you can try but there are too many options to give them here.

  12. If you have other devices attached to your GL.iNet then I found I had to disconnect and reconnect them again to the GL.iNet WiFi for them to then have internet connectivity.

I hope this helps others. As I start to get more confident and try this out more I may find some of the steps are actually not needed. This worked for me just now. I currently have 4 devices connected to it (2 Windows laptops, 1 Android tablet, 1 Android watch and 1 Android phone) and they are all getting internet.

1 Like

thanks for sharing.

Next time I will definitely find a Marriott hotel to try.

I created a blog post out of this at https://blog.pauby.com/post/wifi-captive-portals-connect-travel-router/ - bit more info and structure to it.

I’ve also found Marriott a pain to connect to. Takes some playing to get things working but I usually can make it happen.

They also like to lock out the HDMI ports on the TV’s :rage: I travel with a 750S and Firestick 4k. They make both a pain to use!

This is very bad. Why should they do this? Maybe they need to add in their online booking system: TV HDMI blocked.

I suspect they are trying to push people to use their premium TV services. Many of the Marriott’s have an option where you can log in to your Netflix and Hulu accounts through their system. My guess is once you do that they monitor everything you do and sell your data. You become one big profile for them…

Travel metrics, room service, special requests, hotel restaurant dining, what you watch on TV, what you watch on Netflix and Hulu, internet browsing… They can data mine a staggering amount.

That’s why I love your routers :grinning: At least they are blind to my internet activities :laughing:

stayed at marriot this weekend. horrible results.
ar750 ver 3.1
let’s see where do I start. first I logged in with laptop wifi adapter to hotel wifi to activate captive portal access (name/room number)
I found the default gateway of 172.20.1.1 and the name with …traceroute 8.8.8.8 --resolve-hostname… and added hostname as above.
then I cloned macaddress of laptop wifi to gli-net mac wan and stopped using laptop wifi adatper completely. since I used 2.4ghz on laptop was using 2.4 ghz antenna for ar750. I disabled all ap for 2.4 ghz and 5ghz on ar750 and used ethernet for client device.

I disabled rebind
used default dns settings, enabled stubby, then tried with dnscrypt proxy

tried this

and made it perm in rc.local

then i had enough and gave up and plugged the usb150 into the router and tried it all over with that device. which failed also.

then I decided to use the mac of one of their acess points. still nothing.

after what felt like hours of reboots and modifications and repeat modifications… I gave up

@rp201rp - at which one did you stay? (brand)

I am a platinum elite with them and stay 50-60 nights per year (usually Sheraton, Westin, W, Courtyard, Springhill, Fairfield, Townplace) and never ran into these issues.
I used to use MT300A for the past 2 years but switched to AR750 and AR750s in the last 6-7 months.

In their “older” locations I usually search for a neglected ethernet port under the desk area or in their one of their AP nodes (I ask for such a room upon check in).
in their newer locations (which I usually prefer) I usually can’t find ports or accessible equipment but manage to successfully connect the GL to their wifi.

only quirk I noticed is that even if I do the captive page on the 1st day of the stay and select a 7 day period, it would still require me to do the captive “login” once a day.

as I finished my reply above something dawned on me -
I was told several times in their marketing materials and sometimes by the reception associates that I am entitled to “enhanced wifi” because of my status with Marriott.

then it got me thinking -
is it possible that they purposely make their “free” basic wifi problematic for use with advanced users just so the guest will pay for the upgrade to “enhanced wifi”?
is it possible that this is why I never had issues connecting and using their networks with my GL routers?

am curious if one of the posters in this thread had issues even with elite status

i was trying to get that working, that wouldn’t be fun. :wink:

Check the box on the back of the TV. It may have a LAN port. I’ve found some of them allow full speed internet access if you plug directly in to them.

1 Like

marriot double tree columbus ohio. the carnorivised, coronvirusted, arnold fest. (they cancelled so many events)

I planned to go to Marriott hotel in Thailand.

But I have to cancel because of the covirus.

seems like none of us will be using the “travel” functions of our “travel routers” for quite a while…
take care and be safe and we’ll get back to figuring out the hotel’s techniques when things will return to normalcy.

… not necessarily …

And FWIW, I haven’t had trouble connecting to Marriott-family internet (I get enhanced for free via my status) in well over a year with my Slates running recent firmwares; I’m on one now. Just make sure “DNS Rebinding Protection” is off.

I’ve had mixed success in various hotels, but found a fairly fool-proof way - albeit not fully in keeping with the “this little box does it all” ethos. It was prompted by me having a free Boingo account with my credit card, and for a couple of weeks on a particular site that a group of us were working on the only access that I could get was via Boingo (no cellular coverage, the site owner wasn’t happy giving us access to their wifi as we’d then be inside their network, but their internet was provided by BT Internet, who by default set their routers to give give guest internet-only access to their subscribers or Boingo). The problem with Boingo is it seems to need you to use their app to connect, and I had mixed luck doing that on the laptop then doing the Mac clone stuff.

So, having just replaced my Android phone, I use the old one to do the outward-facing connection to the hotel or commercial wifi, using Boingo or just logging in to their captive portal. That phone is plugged into my Slate’s USB port, select USB tethering on the Android phone and I can then share the connection onwards with the slate, all protected by the VPN from the slate to my brume back at base.

It does mean carrying another phone and cable with me, but that fits into the pouch with the slate so no big deal. That phone is bare except for the web browser and Boingo app. It’s not as neat as doing config changes on the slate, messing with DNS etc., but pretty much always just plugs in and works.

1 Like