Connect to Enterprise WPA

I bought the Mango MT300N-V2 and updated to firmware 2.261. So I’m using full wpad instead of miniwpad. However when I go to advanced settings to try to setup the connection the the Enterprise hotspot(username and password), the scan doesn’t manage to find any wifi networks.

I also got this error above in the Networks --> Wireless menu:


Package libiwinfo required!
The libiwinfo-lua package is not installed. You must install this component for working wireless configuration!


Even though I did manually try to install libiwinfo-lua through the app store.

I’ve read that some other people also had some problems with the V2 version of the GL-MT300N. Could this also be the case here?

-Nick

Hi Nick,

MT300N-V2 use MTK wifi driver not open source driver so the configuration is different. Please omit the libiwinfo-lua info because it is reported wrongly.

We are working on these issues and will upgrade the firmware of MT300N-V2.

@Nick, bad news. The MTK wifi driver doesn’t support EAP as sta. Sorry for this. Hope the open source driver for this model can work.

Update: We are trying to add EAP in MTK driver. Will update later.

Hi Nick,

The property MTK WIFI driver doesn’t support

EAP as STA mode.

Thanks for the reply guys. I’m sorry I’m not very technical in terms of flashing and driver related stuff.

Does not supporting EAP mean that my Mango MT 300N-V2 cannot connect to a Enterprise WPA wifi source and serve as a personal wifi hotspot?

 

Hello,

We have a requirement to connect to WPA Enterprise in client mode.

We purchased 2x GL-MT300N-V2 and GL-AR300M but these do not connect to WPA EAP. The GL-MT300N-V2 does not even scan for Wifi in the advanced settings (luci) with the ‘Package libiwinfo required!’ error.

Please advise which products work with WPA Enterprise or what we can do to get these to work. If this can be solved we will be purchasing many devices.

Regards,

Dan.

AR300M should connect to EAP. You need to use newest firmware v2.261 which as full hostapd/wpa_supplicant installed. Need to do little work in Luci.

Ok - I will purchase the AR300M. As I am ordering to the UK, these will take a while :frowning:

Can you provide a link to the newest firmware please?

Hey! Try doing some work yourself! (top right of screen - Support > Download)

Did anyone figure out the fix for Mango?

Mango uses MTK wifi driver and does not support EAP

Workaround: OpenWRT firmware from here: http://downloads.openwrt.org/releases/18.06.2/targets/ramips/mt76x8/
I use it for WPA Ent, PEAP, EAP-MSCHAP-V2
Works well, one bug that I discovered is that when you do heavy sftp transfer involving first ethernet port (and WiFi), the other port stops responding (it is set to be a LAN instead of WAN port). Weird behavior but I think I messed up something in settings.

1 Like

You are correct. If you use opensource WiFi drivers then it support EAP.

Hi avatar4 would you mind explaining how you set this up or link to instructions? I’m trying to do it and I’ve flashed the OpenWRT that you’ve linked to but still cant see an option for PEAP when connecting to the network.

Thanks

JB

Correctly flash OpenWrt firmware. Instructions and current firmware:
https://openwrt.org/toh/gl.inet/gl.inet_gl-mt300n_v2

Your status screen should look like this:

Your Network|Wireless screen should look like this:

When connecting to or editing connection settings, the option for PEAP should be in Interface Configuration|Wireless Security (at bottom of the page).
Remember to set the correct Authentication method (MS-CHAP in my case works fine, might not in your case)
3

And remember, Google and Wikis are your friend :slight_smile:

Aw thank you so much for that great response. Great help. Cheers. JB

I forgot, you also need to install “wpad”. By default you have “wpad-basic” that is not enought.

1 Like

Hi!, I bought an GL-Inet MT300N-V2 to work as a bridge between a EAP Wireless network (https://telecable.es/wifisfera/linux/Manual%20wifisfera_Linux.pdf) and a Computer, TV, Mobile phone, etc.The solution is for my brother in law, who lives 1000km away from where I live, so I’m configuring the device to send it to him.
I successfully flashed OpenWrt firmware and installed wpad, and now I’m able to configure the connection, but the problem is that when I enable the .wifisfera_telecable client network, at the same time the master network gets disabled, and that not happens when I enable any other client network. Any Idea about why that happens and how to fix it?. The client network isn’t connected (because the network is 1000km away from here), could that be the reason?

Thank you!

When you use luci to set up a station, please uncheck the “replace the current network” option. By default the AP config will be changed to station.