Convexa-B (GL-B1300) Wi-Fi speed 2+ times slower

Hi all.

Just got the router, set it up with the latest OpenWRT (I can revert to the stock if required but prefer not to) and I can see the wireless speed to be around twice as slow as another router I have at home (ASUS RT-AC58U). So when my ASUS shows 500+Mbit/s, the Convexa shows ~200. This is measured with iperf3, so the speed is local and unrelated to my network set up.

I’m new to OpenWRT so please let me know what I can run to help with the diagnosis.
Here’s the wireless config dump (with passwords and ssid’s removed), you can see I’m playing with the locale settings to get different channels and power settings available to me, but no channel change helped so far:

config wifi-device 'radio0'
	option type 'mac80211'
	option hwmode '11g'
	option path 'platform/soc/a000000.wifi'
	option htmode 'HT20'
	option channel 'auto'
	option country 'NZ'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option key ''
	option ssid ''
	option encryption 'psk2'

config wifi-device 'radio1'
	option type 'mac80211'
	option hwmode '11a'
	option path 'platform/soc/a800000.wifi'
	option htmode 'VHT80'
	option country 'AU'
	option channel '144'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option key ''
	option ssid ''
	option encryption 'psk2'

config wifi-iface 'wifinet2'
	option ssid ''
	option device 'radio0'
	option mode 'sta'
	option key ''
	option network 'wwan'
	option encryption 'psk2'
	option disabled '1'

Much appreciated for any help!

stock is using proprietary QSDK drivers.
vanilla Openwrt isn’t, hence the wifi speed degradation.

Thanks for your answer, I didn’t know that.
I know that stock FW has lede OWRT backend, but from a very old version (15 I think?). Is it possible to just upgrade the backend with the newest v19 of OWRT?


Flashed the original latest firmware - still not more than 250Mbit/s even when standing up close to the router.

Maybe you can change the channel and check again?

Ch - Mbit/s
36 - 122
44 - 170
52 - 193
64 - 150
100 - 133
120 - couldn’t connect
157 - 120
165 - 60

If you are using stock firmware and test using cable in wan, it should be faster. 300-600 is normal.

Don’t be too close to the router. 1 meter is good.

I cnanot think of the reasons.

I get 300-500Mbit/s with LAN on CAT6 cable. Do I have a faulty unit? It supposed to be a gigabit router I thought… I’m OK with 500-600Mbit Wi-Fi speeds (although I have a more or less stable 900-1000Mbit uplink to the internet) but having 200Mbit/s is unacceptable.

What would be my next steps?

Thanks for your help.

Hi, what’s your wifi client to do iperf3, PC or phone? Do you use a modifed firmware on ASUS RT-AC58U? Openwrt 19 nat speed on b1300 should be more than 700Mbps. So you can try to change a cable for test I think.

Hi mate, thanks for the reply.
I’m testing with PC, MAC and Android device. All of them are consistent with the speed tests with iperf3.
Nope, stock FW on ASUS. And the Convexa is on the 3.104 firmware with OWRT 15.05.1. As per my first message I was also using the latest available OpenWRT, but got a suggestion to try the stock as the vendor FW might have better drivers for the hardware.

Swapped for three different cables (Cat 5e\6) - same results.

After flashing back to the stock I did a hardware reset (holding reset for 10+ seconds). Nothing else was customized except for the Wi-Fi (basic 2.4 and 5Gbit setup).


Can you private me your email, purchase channel and order number? I’d like to ask customer service to get the device back to check.

Ahh dang it :frowning: I’ve purchased it through Amazon and got it shipped to NZ. Wouldn’t be ideal to send it back as I’ll probably lose more on the shipping costs. Let me reset it once more just in case. I’ll report back later today.

Nope, nothing seem to work - same speeds after another reset :frowning:
I’ll send the order details to you shortly.
Thanks for your help.

Welp, I can’t figure out how to send a private message. Can you ping me so I will reply please? Thanks!

Click on the green A for Alfie and then message :blush:

I have also the same product. I already posted a Topic. This Problem would be solved when we add an external wifi dongle to the device. But I dont know how to add this dongle. Maybe someone here… These insight built chipset in the Gl. inet devices not speed Monsters

Thanks, but I can’t see the message button. Must be because I’m a new user and have limitations (including pasting a screenshot of the popup box when I click on the person’s avatar).
Already contacted by alzhao :slight_smile:

hope someone give us instructions to add wifi dongle in gl. inet

Sorry mate, no idea why would anyone use a Wi-Fi dongle with the Wi-Fi router… Like buying a new car and replacing the engine to a slower one. And this is a bit off-topic for this thread :slight_smile:

1 Like

you are wrong mate… why they offer this feature in the top product BRUME. Just think before write something. Wifi dongles are very usefull and offer more power than built in ones.