Crashed AR300M, NOR ssh cli, but no web ui and no uboot

Hi,

I crashed accidentally an AR300M.

Now I have only NOR ssh cli, but no web ui. I tried to start the uboot, but I didn’t get it running.

Is the procedure on “http://www.gl-inet.com/how-to-enter-the-uboot-web-ui/” not the right way for the AR300M?

Is there a way to flash a new NAND firmware from the NOR ssh cli?

Regards

Stefan Klatt

1 Like

Playing around with firmware I did the exact same thing with my AR300M… I was able to re-flash NAND in Uboot. The directions in the link were a bit off for what I did so here’s my steps:

 

  1. Connect only one cable to the LAN port on the AR300M. The other to your computer.
  2. First, press and hold the Reset button firmly; then power on your device.
  3. The LEDs will start to blink. Keep holding it (about 6 blinks. There is one initial power on blink then 5 after that) until the flashing stops.
  4. Release your fingers.
  5. Set your computer’s IP address to 192.168.1.2
  6. User Firefox or Chrome to visit http://192.168.1.1
  7. Find your firmware and upload (I used openwrt-gl-ar300m-ubi-2.21-3.img)
  8. Wait around 3 minutes. Don’t power down your device while upgrading.
 

Good luck! It took me several times before I got it working.

AR300M’s uboot may boot slow. So just keep the button pressed and wait for the LEDs to flash.

Thanks LostDog. On this way I got the uboot. Probably I didn’t wait not long enough.

I followed these steps. The LED is flashing, and I can access the firmware upload screen. When I select the newest firmware from OpenWrt and press “Upload”, the http connection is reset, and nothing more happens. I can still ping to 192.168.1.1. Is it broken for good?

Also I cannot access the uboot console via serial UART.

Why you cannot access uboot console? Does the serial UART has output at all?

No, the screen stays empty without any output. I tried minicom, screen and kermit. Also the RX/TX leds on the serial adapter do not flash.

First, you need to use a 3.3V USB uart adapter.

Second, you should connect TX, RX and GND correctly. Then there must be output.

I just checked again, sorry my fault. Seems I connected to the PCIE port. Will try again and report success.

I have now connected RX->TX, TX->RX, GND->GND. When I start the AR300 with reset button pressed, the LEDs are not flashing at all. No output on the serial console.
When the serial UART is not connected, I can reset the device and the LEDs are flashig. Then I can connect to http://192.168.1.1 and get the Firmware Update screen. But the connection is reset as soon as I try to upload a firmware file.

Can you give a picture of your uart adapter and the way you connect?

I got one step further. Now I used kermit instead of minicom, now at least there is some output. It says:

U-Boot 1.1.4-g9abb38de (Aug 25 2016 - 08:51:31)

DRAM: ath_ddr_initial_config(219): (16bit) ddr1 init
4 MB

and nothing more. Any more hints?

I know from my AR300M that some uboot loaders seem to not like Windows for some reason. Did you try uploading the firmware from a ubuntu live disk (or something like that)?

I run Debian Linux on my Notebook. No Windows involved.

Can you check if you have set correct baudrate?

It’s set to 115200. And as reported above, I do get some messages now.

If nothing more it seem the router is stuck for some reason.

But if you disconnect uart and uboot still works, it is weird.