Disappointed that VPN client & server cannot be active together

Wow, that’s great ! Many thanks ! I upgraded to 4.2.0 beta2 and it’s working fine ! That should pretty much solve the topic.
However I noticed that for some reason, the Wireguard client seems to stop working after a few hours, it is in yellow status “Client is starting, please wait…” and I need to manually stop and re-start it so it can work again… I need to check further on this issue, I was on phone the few times it happened and the logs were pretty difficult to read there.

I have another question though: is it possible to cascade other LAN services as well ? My question is related to this topic: LAN device cannot request itself through WAN IP and port forwarding - #14 by DuxBellorum
I noticed that I can reach my local services using my non-VPN public IP address, only if the VPN client is inactive. When I’m activating it, it doesn’t work anymore (and I assumed it is the reason why I couldn’t reach the VPN server as well while the VPN client was on). But while I’m not owning the remote VPN server the router’s WG client is connecting to, I cannot choose the ports opened there so I would like that my local services are still available using non-VPN public IP address, even with the VPN client active. Does this sound feasible ?

Just a silly question, but are you trying to reach your router using its LAN IP address ? Like http://192.168.8.1/ ? Because your DDNS address should now resolve as the IP address of the VPN provider you’re connected to, and it’s unlikely that the ports 22/80/443 at this address redirect to your home.

By the way, I think that with a VPN connection active between your device and your AXT, you don’t need remote accesses anymore, because it makes you inside the LAN already.

There is no known bug for ddns and access using http, https and ssh.

As you can use as wireguard server, the ddns should work. Can you verify if the ddns is resolved to correct IP first?

Pls note, as you use vpn client on the router, you have to choose “do not use vpn for glinet services”. If not, then the ddns will resolve to your vpn server IP, not your ISP IP.

Yes, I’m using the DDNS address as I’m not connected with the Wifi.
The reason I want the http/https/ssh connection is if I need to change some configuration or reboot the VPN remotely, I will be able to do that.

Yes, the DDNS is being resolved to the right IP.

It should work. Can you change the ports in port forward settings?

e.g.
2222 to 22
8080 to 80
4433 to 443

Nothing, probably is something related with my router so.
If you don’t relate any problem.
I will try to disable the Wireguard and test it again, just to make sure.

I found it.
If you turn off the WG VPN Client on the router, the external access work’s.

In my option this should not be related.
The http/https/ssh should not use the VPN to forwarder this input ports.

“Services from GL.iNet Use VPN” is turned off.
Someone treaty DDNS as a “Services from GL.iNet” but forgot to put the http/https/ssh together with it.
Can you check an open a ticket for it?

Right. This seems an issue. the ssh/http is only firewall thing. Maybe you can use vpn policy to not use vpn for those servers.

What is your suggestion for that?
Today I use the Policy to Guest Network don’t use VPN.
Because I need this option, to have VPN/non-VPN at the same time here.
I did not find any information about the “Customize Routing Rules - You can manually configure routing rules for each VPN client instance.”

Use vpn policy, mac based policy and not use vpn for the device you want to access using the ddns.

1 Like

I can confirm I was having the same problem as OP on Slate AX with release firmware 4.1.0. After doing a local upgrade to 4.2.0 beta2 firmware, all my problems with having both Wireguard VPN server/client active at the same time were automatically resolved.

I’m also excited to test the VPN cascading function on the VPN server, though I don’t know how that will work if the device I’m using to tunnel into my VPN server was already assigned to use VPN client previously. Fingers crossed it all just works correctly together. This is turning out to be an excellent purchase for me!

1 Like

Am I the only one whose VPN connection using VPN client is constantly dropping? After a few hours working, the VPN connection drops and does not automatically reconnect unless I manually stop and start it again. And in the meanwhile, it can’t access Internet anymore.
I tried to change target server, I even reseted firmware, but without success.

Is it a bug in 4.2.0 beta2 ?

Without vpn, is the internet normal?

Yes it is, without VPN as well as with VPN when client is correctly started. It’s just that after some time it turns yellow and remains in “Client starting please wait” status unless I manually stop and restart it. And during this time, Internet is KO.

Edit: browsing the forum, it seems like I’m not the only one experiencing this, with a different VPN service provider than mine. Firmware 4.2.x is out as snapshot firmware - #101 by mainufer Solution is not clearly identified yet though.

There is a issue with loading 2 or more VPN config files that causes everything to wipe and the vpn to get stuck in connecting. Also had it happen if I reloaded a backup config that had more then 10 vpn config files already.

Can you start a new thread with the details of the issue? e.g. vpn service provider, ISP and openvpn or wireguard?

I could go up to the old thread to make a guess but this thread is for other discussion. If you don’t want to post too much details you can email us.

Yes, I actually posted the details of this issue on the other thread where someone faced the same: Firmware 4.2.x is out as snapshot firmware - #191 by DuxBellorum

That is also another long thread and not good to post your issues there.

You can also email us support at glinet.biz I will try my best to help. But it is hard for me to track issues in long thread.

Alright, dedicated thread created, here it is: Wireguard client connection dropping and not reconnecting