Endless loop wireguard client


I found several similar topics without any solutions which works for my issue.

I’ve bought me a GL-AXT 1800 recently with the objective to connect all family devices to a hotel or to a more or less public WiFI. And to connect all of us to our home network via a VPN client. I think it is called Lan-To-Lan.
Anyway I setup a Wireguard server via pivpn in my home network. It works smoothly with all devices. But with the GL-AXT 1800 I get an endless loop during the setup of the wireguard connection. But any connection couldn’t be established. The logs on the web page show the same result like many other postings here.
I tried to use my public IPv4 address. The same result except here I could see some traffic on the wireguard server. But it seems it was just some protocol overhead as the router haven’t been seen yet for the wireguard server.
Is this a bug in the firmware? will it be fixed?
which logs I can checks on the router. The wireguard directory is empty.
Any hints are welcomed.


First, welcome.

Second, all of these threads look the same because part of Wireguard’s “elegance” or “lack of complexity” or whatever other words the stans want to use includes the fact that its logging sucks and doesn’t give you any useful information about what the problem is. So everything ends up being a “rekey timeout”. IPSec logs may be impossible to understand, but at least they contain the information you need to fix the problem.

That said, the two most common problems for something like this are:

  1. a settings mismatch or
  2. a firewall/network issue preventing the traffic from getting to the server.

I would check very carefully to make sure you’ve got all the settings correct on the client side, especially if you entered them manually. I was setting up a test server yesterday and entered both the IP and the port wrong by one number.

Second, I would make sure everything is working on your server side in terms of firewalling / port forwarding. If you’re on your LAN, you might try directly entering in the local address of your Pi to make sure you can connect without any issues there.

Once you confirm both of those things, we can start trying to take the problem apart to see if we can find a solution.

Thx for the response. I will double check everything. But the vpn-server on my raspi behind a router works. At least it is my assumption as I can connect via my mobile (5G) to my home network. Further I can see some traffic once I configured the public IPv4 address in the wireguard conf on the GLi_router.
But one additional thing - I removed the preshared key from the WG-conf on client (GLI) and server side (home router).
But I will double check it again.

1 Like

If your other clients are connected externally that’s a good sign. Are you also trying to connect the GLI from an external network?

yes via tethering from my mobile

So I know with SurfShark vpn form some reason I need to create a new private key and public key for every configuration that I try in the router. alzhao did mention something in one of the post about some VPN pre-shared keys are not recognized.

It is a year old but some good info here:

Could you try generating a new public and private key for the config.