Failure to install File Sharing

On my MT1300 there are two plugins listed

gl-files-brower
gl-files-browser

both have to be installed for file sharing to work for me

Doesn’t exist for me. Our problem is with the beta build. The stable one works out of the box.

USB stick would tie up the only USB port, so you cannot use it for tethering, other USB drives, wifi dongle, etc. Also, the USB stick will protrude, so not so good for travelling.

It may be better to do the same on a microSD card, which I keep inserted.

Thanks but my point is that I could not install Luci in the first place on the Spitz. This is even on a completely fresh firmware install without saving any settings or keeping any packages. Really frustrating.

Would be kind enough to provide an easy guide as to how to use the microSD to expand device storage (that is if I can manage to eventually install Luci by some sort of a miracle).

Yes, you are right, SD is better and it doesn’t use the USB port for if you want Tethering, but Spitz is an LTE modem, I find it redundant to use tethering on the Spitz.

And to avoid the big big lumps outside the router, I have seen these very small USB Sticks.

image

1 Like

Yes, with my 2 AR750 I had this same problem at the beginning, when updating there is not enough space to install anything nor Luci.

Look that when you have rebooted the router you have almost 2 MB free which is enough for Luci.

I remember updating the firmware and disconnecting the router from the Internet, then in Web Admin I set the password and nothing else, and then I go directly to Advanced> Install luci, I connect the router to the Internet of course just for that and if Luci OK, I do Mountpoint / overlay with an external storage device right after, and when it has been done successfully, you have to restart the router and you have to reconfigure the password as if it were the first time you started the router.

I noticed when the router was connected to the internet this 2MB free space would start to shrink little by little. It can be logs, statistics, etc …

Try it. I have firmware 3.211 installed on the 2 AR750s, I think beta 1, I’m not at home right now.

1 Like

In case other forum readers with other router models (not only Spitz) may be considering using a USB stick for /overlay, I just wanted to note some factors to consider regarding a USB stick that would tie up the USB port.

1 Like

I have not personally moved /overlay to a microSD card, nor USB stick, so I would not want to provide specific instructions on doing that without testing it first.

You can follow the procedure that @David has provided. There are also guides that you can Google “extroot” for. Note that there would be some risk in case the external storage is accidentally removed due to handling (you can put some tape over the microSD slot).

Although LuCI is good to have, I do not find that it completely replaces the GL.iNet UI because the LuCI UI is more complicated for basic tasks. Once you have your router set up to what you want it to do, LuCI may not be necessary.

At this point, are there problems with your Spitz that have not been resolved? Maybe they can be fixed with SSH commands without installing LuCI. In fact, the GL.iNet UI and LuCI UI are just front-ends to the Openwrt commands.

If you still want to install LuCI, it may be easier to free up storage space by uninstalling some installed packages that you do not use. Examples are AdGuard, extra wifi drivers, PPP/PPPoE. At the bottom of the GL.iNet → APPLICATIONS → Plug-ins page, the amount of Free space should be displayed, which should help determine the amount of extra space needed.

1 Like

I tried all the suggestions to install file sharing still no good tried the new snapshot still no good any ideas
openwrt-mv1000-emmc-3.211-0108.img

OK packages uploading. Pls check back in a few days.

Ok great, many thanks much appreciated not urgent as I’m using the GL-AX1800

Just tried the snapshot openwrt-mv1000-emmc-3.211-0110 still no file sharing i did revert the firmware as well as fresh install, restarted quite a few times plug-ins updated

1 Like

It turned out to arrange the download of the plugin, through WinSCP in the etc/resolv.conf directory I registered 1.1.1.1 and 1.0.0.1