[Feature Request] USB 3.0 & 2.4GHz Interference; possible solution(s)


Because USB 3.0 has significant interference with 2.4GHz WiFi, when the external storage is connected, it becomes almost impossible to use 2.4GHz anymore.

Is there any possibility to toggle USB 2 ONLY mode to address this issue?
Upon searching, there are some discussions into this possibility in some OpenWrt forums, and one even shared a screenshot of their image showing the implementation of such mode:

Is it something that can be considered as an add-on option for GL.iNet firmwares?
This way, we can enjoy plugging external storage while not having to sacrifice 2.4GHz frequency. Even at the expense of some transfer speed loss due USB 3 vs USB 2, it will be well worth it for some users.

Hey, correct me if I’m wrong but wasn’t there another recent thread that your post relates to? If so, could you link it here to keep it consolidated? I thought I saw one but don’t recall if I read it.

Perhaps the source thread on the OWRT forum wouldn’t be amiss either.

(I took the liberty of re-titling your post.)

As myself mentioned in my post:

Primary source(s) are always important. I’m sure it’s still in your browser history, no?

Idk if this works but give it a try? These commands configure the USB ports to use the OHCI driver (USB 1.1/2.0) and disable the EHCI driver (USB 3.0).

uci set ohci.@global[0].init=‘1’
uci set ohci.@global[0].enabled=‘1’
uci set ehci.@global[0].enabled=‘0’
uci commit
/etc/init.d/usb restart

Some discussions here:

and a hint on OpenWrt user guides:
“disable the USB3 driver to force fallback to USB 2.0. Many current OpenWrt devices aren’t even noticably faster on USB3.0 data transfers compared to 2.0.”

but none I could find with a clear solution, not at least for Glinet firmwares.


I had very similiar isues.

I sorted it out with replacing the power cable with a very thick shielded one and a long cable that connects to the USB3 drive and also putting the drive further away from the router. Seems to be working without issues so far.


I wonder if mere RFI cable clamp(s) wouldn’t do it.


Isn’t ‘xhci’ for USB 3.0?

I haven’t tried your suggestion yet, but if it works, that would be a good solution. I rather trade off the benefits of USB 3.0 (if any on owrt os anyway?!) for a stable connection on 2.4ghz.

What other people are suggesting (e.g. using a thick shielded cable, or to put the USB 3.0 storage farther away) haven’t worked out in my case. My Beryl AX is set up as subnet, and oddly enough, when I connect USB 3.0 device, it interferes even with the primary router which is relatively far away.

Yeah, you’re right. it is xhci. IDK if that particular string is recognized by UCI or if it’s just amalgamated into ohci.

You could always try a low tech approach a-la a Faraday cage: wrap/seal your USB3 device in a few layers of tin foil.

You’re correct. NVM on the commands then.

The OHCI and UHCI controllers support only USB 1 speed devices (1.5 Mbit/s and 12 Mbit/s), and the EHCI only supports USB 2 devices (480 Mbit/s).

The xHCI architecture was designed to support all USB speeds, including SuperSpeed (5 Gbit/s) and future speeds, under a single driver stack.