File Sharing Via Samba- Unable to Write Files

Hello- Just received a GL-MT3000 and am having a great time digging in. Great product.

One challenge I can’t solve that I’m looking for assistance with.


  • Unable to write files to a share USB thumb drive (Via SAMBA)


  • Cannot copy any actual files (excel, word, jpeg, etc… Nothing).
  • Can find the shared disk no problem on multiple computers
  • Can create new folder no problem. Can copy an empty folder from my computers to the shared drive no problem.


  • Tried reformatting memory stick (SanDisk USB 3 Drive)
  • Tried accessing from multiple machines and all throw an error when trying to write a file (Mac and PC)
  • Tried rebooting Router
  • Tried multiple USB memory sticks
  • Tried playing with various settings
  • Checked for security settings and everything is off (that I could find)
  • Firmware appears to be up to date.

Any thoughts? Seems to be something blocking it within the router

Many thanks!

Are you using macOS and experiencing a similar issue to the one described in this post?

Hello- I read that, and my issues are different.

  • I’m unable to copy from a PC onto the shared folder.
  • Happens with Windows 10 and 11 and Mac OS
  • I can’t copy an individual file or a folder filled with files. I can copy an individual empty folder.


Found the problem… Reformatted the drives as NTSF and everything works fine.

1 Like